<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Kaman introduces Advanced Memory and Data Exchange Universal System — General Aviation News</title>		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='contextly-page' id='contextly-page' content='{"title":"Kaman introduces Advanced Memory and Data Exchange Universal System","url":"https:\/\/generalaviationnews.com\/2018\/01\/05\/kaman-introduces-advanced-memory-and-data-exchange-universal-system\/","pub_date":"2018-01-05 07:46:55","mod_date":"2018-01-04 13:11:37","type":"post","post_id":116165,"author_id":"2456","author_name":"General Aviation News Staff","author_display_name":"General Aviation News Staff","tags":["Aviation News","General Aviation"],"categories":["Products"],"image":"https:\/\/generalaviationnews.com\/wp-content\/uploads\/2018\/01\/Kaman-AMADEUS-3.jpg"}' /><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="General Aviation News &raquo; Feed" href="https://generalaviationnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="General Aviation News &raquo; Comments Feed" href="https://generalaviationnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="General Aviation News &raquo; Kaman introduces Advanced Memory and Data Exchange Universal System Comments Feed" href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/feed/" />
<link rel="canonical" href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/generalaviationnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='news-pro-theme-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='tve_style_family_tve_flt-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-visual-editor/editor/css/thrive_flat.css?ver=2.0.16' type='text/css' media='all' />
<link rel='stylesheet' id='tve_leads_forms-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-leads/editor-layouts/css/frontend.css?ver=2.0.17' type='text/css' media='all' />
<link rel='stylesheet' id='js-job-styles-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/gan-js-firm-jobs/css/js-jobs.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-style-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='footable-core-min-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/footable/css/footable.core.min.css?ver=0.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/pro/assets/css/ubermenu.min.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-white-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/pro/assets/css/skins/white.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-font-awesome-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/assets/css/fontawesome/css/font-awesome.min.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.7' type='text/css' media='all' />
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/gan-js-firm-jobs/js/js-jobs.js?ver=2.7'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/js/gan.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/footable/js/footable.min.js?ver=0.3.1'></script>
<link rel='https://api.w.org/' href='https://generalaviationnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://generalaviationnews.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://generalaviationnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgeneralaviationnews.com%2F2018%2F01%2F05%2Fkaman-introduces-advanced-memory-and-data-exchange-universal-system%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://generalaviationnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgeneralaviationnews.com%2F2018%2F01%2F05%2Fkaman-introduces-advanced-memory-and-data-exchange-universal-system%2F&#038;format=xml" />


<script type="text/javascript">
  (function(w, d, id, ns, s) {
    var c = w[ns] = w[ns] || {};
    if (!c.ready) {
      c.q = [];
      c.ready = function() {
        c.q.push(arguments);
      };
            c.ready.apply(c, ["expose",{"wp\/widgets":{"dependencies":["widgets"],"js":["https:\/\/assets.contextly.com\/wp-plugin\/5.0.1\/js\/contextly-wordpress.js"],"foreign":true}}]);
            c.ready.apply(c, ["libraries",{"jquery":false}]);
            c.ready.apply(c, ["load","wp\/widgets"]);
          }

        if (!d.getElementById(id)) {
      var e = d.createElement(s);
      e.id = id;
      e.src = "https:\/\/assets.contextly.com\/kit\/5.latest\/loader.js";
      var h = d.getElementsByTagName(s)[0];
      h.parentNode.insertBefore(e, h);
    }
      })(window, document, 'ctx-loader', 'Contextly', 'script');

  (function(c, ns){var v=c[ns]=c[ns]||{};v["appId"]="generalaviationnews";v["https"]=true;v["client"]={"client":"wp","version":"5.0.1"};})(Contextly,"overrides");(function(c, ns){var v=c[ns]=c[ns]||{};v["ajax_url"]="https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php";})(Contextly,"wpdata");</script>

<!-- Plugin: Open external links a new window. Plugin by Kristian Risager Larsen, http://kristianrisagerlarsen.dk . Download it at http://wordpress.org/extend/plugins/open-external-links-in-a-new-window/ -->
<script type="text/javascript">//<![CDATA[
	function external_links_in_new_windows_loop() {
		if (!document.links) {
			document.links = document.getElementsByTagName('a');
		}
		var change_link = false;
		var force = '';
		var ignore = '';

		for (var t=0; t<document.links.length; t++) {
			var all_links = document.links[t];
			change_link = false;
			
			if(document.links[t].hasAttribute('onClick') == false) {
				// forced if the address starts with http (or also https), but does not link to the current domain
				if(all_links.href.search(/^http/) != -1 && all_links.href.search('generalaviationnews.com') == -1) {
					// alert('Changeda '+all_links.href);
					change_link = true;
				}
					
				if(force != '' && all_links.href.search(force) != -1) {
					// forced
					// alert('force '+all_links.href);
					change_link = true;
				}
				
				if(ignore != '' && all_links.href.search(ignore) != -1) {
					// alert('ignore '+all_links.href);
					// ignored
					change_link = false;
				}

				if(change_link == true) {
					// alert('Changed '+all_links.href);
					document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
					document.links[t].removeAttribute('target');
				}
			}
		}
	}
	
	// Load
	function external_links_in_new_windows_load(func)
	{	
		var oldonload = window.onload;
		if (typeof window.onload != 'function'){
			window.onload = func;
		} else {
			window.onload = function(){
				oldonload();
				func();
			}
		}
	}

	external_links_in_new_windows_load(external_links_in_new_windows_loop);
	//]]></script>

<style id="ubermenu-custom-generated-css">
/** UberMenu Custom Menu Styles (Customizer) **/
/* main */
 .ubermenu-responsive-toggle-main, .ubermenu-main, .ubermenu-main .ubermenu-target, .ubermenu-main .ubermenu-nav .ubermenu-item-level-0 .ubermenu-target { font-family:Helvetica, Arial, sans-serif; }
 .ubermenu-main, .ubermenu-main .ubermenu-target, .ubermenu-main .ubermenu-nav .ubermenu-item-level-0 .ubermenu-target { font:bold 12px/24px Helvetica, Arial, sans-serif; }


/* Status: Loaded from Transient */

</style><link rel="icon" href="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/images/favicon.ico" />
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N9M565');</script>
<!-- End Google Tag Manager -->

<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
var _avp = _avp || [];
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript'; s.async = true; s.src = window.location.protocol + '//generalaviationnews.advertserve.com/js/libcode3.js';
  var x = document.getElementsByTagName('script')[0];
  x.parentNode.insertBefore(s, x);
})();
</script>
<!-- END ADVERTSERVE CODE --><style type="text/css">.site-title a { background: url(https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2014/10/GAN1.jpg) no-repeat !important; }</style>
<meta property="og:image" content="https://generalaviationnews.com/wp-content/uploads/2018/01/Kaman-AMADEUS-3.jpg"><meta property="og:image:width" content="1024"><meta property="og:image:height" content="768"><link rel="image_src" href="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2018/01/Kaman-AMADEUS-3.jpg"><script type="text/javascript">/* FooTable init code */

var $FOOTABLE = $FOOTABLE || {};
(function( $FOOTABLE, $, undefined ) {

	jQuery.fn.attrAppendWithComma=function(a,b){var c;return this.each(function(){c=$(this),void 0!==c.attr(a)&&""!=c.attr(a)?c.attr(a,c.attr(a)+","+b):c.attr(a,b)})};jQuery.fn.footableAttr=function(a,b){return this.each(function(){var c=$(this);c.data("auto-columns")!==!1&&(c.find("thead th:gt("+a+")").attrAppendWithComma("data-hide","tablet"),c.find("thead th:gt("+b+")").attrAppendWithComma("data-hide","phone"))})},jQuery.fn.footableFilter=function(a){return this.each(function(){var b=$(this);b.data("filter")||b.data("filter")===!1||b.data("filter-text-only","true").before('<div class="footable-filter-container"><input placeholder="'+a+'" style="float:right" type="text" class="footable-filter" /></div>')})},jQuery.fn.footablePager=function(){return this.each(function(){var a=$(this);if(a.data("page")!==!1){var b=$('<tfoot class="hide-if-no-paging"><tr><td><div class="pagination pagination-centered"></div></td></tr></tfoot>');b.find("td").attr("colspan",a.find("thead th").length),a.find("tbody:last").after(b)}})};

	$FOOTABLE.init = function() {
		$(".footable")
			.footableAttr(4,1)
			.footable( { breakpoints: { phone: 320, tablet: 768 } });

	};
}( $FOOTABLE, jQuery ));

jQuery(function($) {
	$FOOTABLE.init();
});
</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Kaman introduces Advanced Memory and Data Exchange Universal System" />
<meta property="og:url" content="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/" />
<meta property="og:description" content="The Memory Division of Kaman Precision Products has introduced the AMADEUS — the Advanced Memory and Data Exchange Universal System. The AMADEUS includes the Model 9740 Multi-Port data transfer uni…" />
<meta property="article:published_time" content="2018-01-05T15:46:55+00:00" />
<meta property="article:modified_time" content="2018-01-04T21:11:37+00:00" />
<meta property="og:site_name" content="General Aviation News" />
<meta property="og:image" content="http://generalaviationnews.com/wp-content/uploads/2018/01/Kaman-AMADEUS.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="795" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@genavnews" />
<meta name="twitter:text:title" content="Kaman introduces Advanced Memory and Data Exchange Universal System" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@genavnews" />
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.
Click the help icon above to learn more.
*/		</style>
	</head>
<body class="post-template-default single single-post postid-116165 single-format-standard custom-background custom-header header-image content-sidebar" itemscope itemtype="https://schema.org/WebPage"><!-- Google Tag Manager (noscript) --><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N9M565" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><!-- End Google Tag Manager (noscript) --><div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://generalaviationnews.com/">General Aviation News</a></p></div><div class="widget-area header-widget-area"><section id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_1">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_1', alias: '/', type: 'banner', zid: 1, pid: 0 });
</script>
</div></div></div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap">
<!-- UberMenu [Configuration:main] [Theme Loc:primary] [Integration:auto] -->
<a class="ubermenu-responsive-toggle ubermenu-responsive-toggle-main ubermenu-skin-white ubermenu-loc-primary ubermenu-responsive-toggle-content-align-left ubermenu-responsive-toggle-align-full " data-ubermenu-target="ubermenu-main-3063-primary-2"><i class="fa fa-bars"></i>Menu</a><nav id="ubermenu-main-3063-primary-2" class="ubermenu ubermenu-nojs ubermenu-main ubermenu-menu-3063 ubermenu-loc-primary ubermenu-responsive ubermenu-responsive-default ubermenu-responsive-collapse ubermenu-horizontal ubermenu-transition-slide ubermenu-trigger-hover_intent ubermenu-skin-white  ubermenu-bar-align-full ubermenu-items-align-left ubermenu-bound ubermenu-sub-indicators ubermenu-retractors-responsive"><ul id="ubermenu-nav-main-3063-primary" class="ubermenu-nav"><li id="menu-item-73290" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73290 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/" tabindex="0" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">News</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-73290 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width"  ><!-- begin Tabs: [Tabs] 115061 --><li id="menu-item-115061" class="ubermenu-tabs menu-item-115061 ubermenu-item-level-1 ubermenu-column ubermenu-column-full ubermenu-tab-layout-left"><ul  class="ubermenu-tabs-group ubermenu-column ubermenu-column-1-5 ubermenu-submenu ubermenu-submenu-id-115061 ubermenu-submenu-type-auto ubermenu-submenu-type-tabs-group"  ><li id="menu-item-73294" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73294 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/accident-reports/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Accidents</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-73294 ubermenu-submenu-type-tab-content-panel ubermenu-submenu-grid"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115066] count[4] --><li id="menu-item-115066-post-115743" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115066 ubermenu-item-115066-post-115743 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/05/carb-icing-contributes-to-forced-landing/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Carb icing contributes to forced landing</span><div class="gan-uber-excerpt clearfix"><p>The private pilot reported that the engine cylinders had been replaced and the flight was to continue a cylinder break-in period. The engine run-up and propeller check were completed during the taxi to the runway to keep the ground run-up to a minimum.</p></div></a></li><li id="menu-item-115066-post-115735" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115066 ubermenu-item-115066-post-115735 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/04/pilots-improper-maintenance-leads-to-fatal-crash/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Pilot&#8217;s improper maintenance leads to fatal crash</span><div class="gan-uber-excerpt clearfix"><p>The private pilot conducted a 20-minute local flight in the Eros 1600, an experimental, amateur-built airplane, after installing a new ignition coil on the two-stroke, two-cylinder engine.

He then returned to the airport in Lebanon, Tennessee, where he landed the airplane, back-taxied on the runway, and initiated a second takeoff.</p></div></a></li><li id="menu-item-115066-post-115740" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115066 ubermenu-item-115066-post-115740 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/03/aerobatic-flight-in-yak-ends-fatally/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Aerobatic flight in Yak ends fatally</span><div class="gan-uber-excerpt clearfix"><p>The pilot was conducting a local aerobatic flight with a pilot-rated passenger occupying the rear seat of the Yak 52, which was equipped with flight controls.

The pilot's son was flying another airplane, returning to the home airport after a local sightseeing flight near Alpine, Wyoming.</p></div></a></li><li id="menu-item-115066-post-115746" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115066 ubermenu-item-115066-post-115746 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/02/fatigue-cracks-contribute-to-accident/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Fatigue cracks contribute to accident</span><div class="gan-uber-excerpt clearfix"><p>Shortly after departure on a local flight, the private pilot observed that the Velocity's engine temperature was higher than it had been on the previous day's flight.

After reducing power, the engine began to surge, which prompted him to return to the airport in Rosamond, California.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115066] --><li id="menu-item-115073" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115073 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/accident-reports/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Accident Articles</span></a></li></ul></li><li id="menu-item-73291" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73291 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/aircraft-news/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Aircraft</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-73291 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115067] count[4] --><li id="menu-item-115067-post-116024" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115067 ubermenu-item-115067-post-116024 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/02/cubcrafters-now-accepts-bitcoin/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">CubCrafters now accepts BitCoin</span><div class="gan-uber-excerpt clearfix"><p>CubCrafters now accepts BitCoin, as well as other popular cryptocurrencies, as a payment method on orders for new and pre-owned aircraft and aircraft kits.

The move supports progressive technologies and the international entrepreneur communities who use them, according to Jim Richmond, the company's founder and CEO.</p></div></a></li><li id="menu-item-115067-post-115894" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115067 ubermenu-item-115067-post-115894 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/21/two-firsts-for-two-eaa-chapter-534-members/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Two firsts for two EAA Chapter 534 members</span><div class="gan-uber-excerpt clearfix"><p>By TED LUEBBERS

One member of Experimental Aircraft Association Chapter 534 recently received an Airworthiness Certificate for his aircraft building project from another chapter member who did his first airworthiness inspection as a newly minted Designated Airworthiness Representative.</p></div></a></li><li id="menu-item-115067-post-115891" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115067 ubermenu-item-115067-post-115891 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/21/hartzell-prop-chosen-for-airvan-10/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Hartzell Prop chosen for Airvan 10</span><div class="gan-uber-excerpt clearfix"><p>Mahindra Aerospace has chosen Hartzell Propeller's three-blade 84-inch diameter aluminum propeller for its Airvan 10 single engine turbine-powered utility aircraft, certified earlier this year.

Hartzell's lightweight hub turbine propeller is constant speed, feathering, reversing and optimized for an improved climb rate, according to Hartzell officials.</p></div></a></li><li id="menu-item-115067-post-115511" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115067 ubermenu-item-115067-post-115511 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/05/us-sport-planes-named-jabiru-lsa-distributor/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">US Sport Planes named Jabiru LSA distributor</span><div class="gan-uber-excerpt clearfix"><p>US Sport Planes of Denton, Texas, has been appointed the North American importer and distributor for Jabiru Light-Sport Airplanes for North America. The company will be the exclusive importer and market the full line of LSA airplanes manufactured in Australia by Jabiru Aircraft.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115067] --><li id="menu-item-115071" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115071 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/aircraft-news/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Aircraft Articles</span></a></li></ul></li><li id="menu-item-73296" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73296 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/airports-news/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Airports</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-73296 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115068] count[4] --><li id="menu-item-115068-post-115527" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115068 ubermenu-item-115068-post-115527 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/06/sunrise-valley-ranch-airstrip-in-oregon-gets-faa-identifier/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Sunrise Valley Ranch Airstrip in Oregon gets FAA identifier</span><div class="gan-uber-excerpt clearfix"><p>Sunrise Valley Ranch Airstrip east of Prineville, Oregon, just got an FAA identifier: 29OR.

According to officials with the Recreational Aviation Foundation, RAF Oregon Liaison Richard Mayes worked hard with the owners to make this happen, originally identifying the potential airstrip location and runway alignment for safe approaches, aircraft parking area and access.</p></div></a></li><li id="menu-item-115068-post-115307" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115068 ubermenu-item-115068-post-115307 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/23/springfield-branson-airport-revitalized/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Springfield-Branson Airport revitalized</span><div class="gan-uber-excerpt clearfix"><p>A grant from the Missouri Department of Transportation to revitalize about 10 acres of property at Springfield-Branson National Airport (KSGF) has served as a catalyst for improvement projects to meet increased demand.</p></div></a></li><li id="menu-item-115068-post-115021" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115068 ubermenu-item-115068-post-115021 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/13/nbaa-files-final-brief-over-smo-closing/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">NBAA files final brief over SMO closing</span><div class="gan-uber-excerpt clearfix"><p>The National Business Aviation Association (NBAA) has filed its final brief before the U.S. Court of Appeals for the District of Columbia Circuit challenging the legality of the settlement agreement reached earlier this year between the FAA and the city of Santa Monica, California, over the future of Santa Monica Municipal Airport (SMO.)

The Nov.</p></div></a></li><li id="menu-item-115068-post-114960" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115068 ubermenu-item-115068-post-114960 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/11/kbzn-opens-new-5050-runway/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">KBZN opens new 5,050 runway</span><div class="gan-uber-excerpt clearfix"><p>A new 5,050' asphalt runway at Bozeman Yellowstone International Airport (KBZN) will help separate general aviation from the airport’s commercial traffic, creating a more efficient environment for transient aircraft operations and flight training.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115068] --><li id="menu-item-115072" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115072 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/airports-news/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Airport Articles</span></a></li></ul></li><li id="menu-item-73298" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73298 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/avionicsinstruments/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Avionics &#038; Instruments</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-73298 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115069] count[4] --><li id="menu-item-115069-post-116148" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115069 ubermenu-item-115069-post-116148 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/04/duncan-aviation-updates-free-s-b-straight-talk-book/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Duncan Aviation updates free S-B Straight Talk Book</span><div class="gan-uber-excerpt clearfix"><p>Duncan Aviation has updated its free Straight Talk book on Automatic Dependent Surveillance-Broadcast (ADS-B), one of the FAA’s mandated NextGen upgrades.

Originally written in February 2015 and periodically updated by a team of Duncan Aviation’s avionics professionals, the Straight Talk book is intended to provide practical information about all aspects of ADS-B for aircraft owners.</p></div></a></li><li id="menu-item-115069-post-116109" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115069 ubermenu-item-115069-post-116109 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/03/garmin-begins-shipping-gfc-500-autopilot/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Garmin begins shipping GFC 500 autopilot</span><div class="gan-uber-excerpt clearfix"><p>Garmin has received FAA Supplemental Type Certification (STC) for several aircraft models for the GFC 500 autopilot, including a wide range of Cessna 172 and 182 aircraft.

Intended for less complex piston single-engine aircraft, the GFC 500 integrates with the G5 to provide pilots with an economical autopilot and modern flight instrument, according to Garmin officials.</p></div></a></li><li id="menu-item-115069-post-113932" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115069 ubermenu-item-115069-post-113932 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/10/05/astronics-max-viz-hits-milestone/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Astronics Max-Viz hits milestone</span><div class="gan-uber-excerpt clearfix"><p>EAST AURORA, N.Y. — Astronics Max-Viz reports that more than 2,500 of its Enhanced Vision Systems (EVS) have now been installed in rotary- and fixed-wing aircraft.

Of the 2,500 installed systems, approximately 60% are on fixed-wing general aviation aircraft and 40% are operating on helicopters.</p></div></a></li><li id="menu-item-115069-post-113279" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115069 ubermenu-item-115069-post-113279 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/09/18/more-than-40000-aircraft-now-equipped-with-ads-b/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">More than 40,000 aircraft now equipped with ADS-B</span><div class="gan-uber-excerpt clearfix"><p>As of Sept, 1, 2017, rule-compliant Automatic Dependent Surveillance-Broadcast (ADS-B) equipment is now on board more than 40,000 aircraft flying in the United States.

The FAA estimates that 100,000 to 160,000 general aviation aircraft will need to be equipped with ADS-B Out before the Jan.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115069] --><li id="menu-item-115075" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115075 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/avionicsinstruments/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Avionics &#038; Instruments Articles</span></a></li></ul></li><li id="menu-item-73295" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73295 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/flight-training/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Flight Training</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-73295 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115070] count[4] --><li id="menu-item-115070-post-116157" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115070 ubermenu-item-115070-post-116157 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/04/ohio-freshman-wins-scholarship/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Ohio freshman wins scholarship</span><div class="gan-uber-excerpt clearfix"><p>DAYTON, Ohio — The National Aviation Heritage Alliance (NAHA) has awarded its annual Mitchell Cary-Don Gum Memorial Aviation Scholarship to Alex Hackney, 15, son of Paul and Rebecca Hackney of Jamestown, Ohio, where Alex is a freshman at Greeneview High School.</p></div></a></li><li id="menu-item-115070-post-116022" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115070 ubermenu-item-115070-post-116022 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/02/applications-now-open-for-ladieslovetaildraggers-scholarships/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Applications now open for LadiesLoveTaildraggers scholarships</span><div class="gan-uber-excerpt clearfix"><p>Applications are now being accepted for the 2018 LadiesLoveTaildraggers’ scholarships.

A variety of scholarships are offered, and for the first time, all flight training will be performed by women CFIs or women-owned flight schools, according to association officials.</p></div></a></li><li id="menu-item-115070-post-115883" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115070 ubermenu-item-115070-post-115883 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/20/10000-in-scholarships-available/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">$10,000 in scholarships available</span><div class="gan-uber-excerpt clearfix"><p>Applications are being taken through Jan. 8, 2018, for several scholarships offered through Women in Corporate Aviation (WCA).

The scholarships include:

 	The $1,700 Air Training International Flight Procedures Training Scholarship for international flight procedures training.</p></div></a></li><li id="menu-item-115070-post-115824" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115070 ubermenu-item-115070-post-115824 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/19/applications-now-open-for-upwind-flight-training-scholarships/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Applications now open for Upwind flight training scholarships</span><div class="gan-uber-excerpt clearfix"><p>SAN CARLOS, California — The Upwind Foundation is now accepting applications for its 2018 scholarships.

Now in its sixth year, Upwind provides scholarships that include flight and ground training for high school students to prepare them to get their Private Pilot certificate during the summer between their junior and senior years.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115070] --><li id="menu-item-115074" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115074 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/flight-training/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Flight Training Articles</span></a></li></ul></li><li id="menu-item-115060" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115060 ubermenu-item-auto ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">All News</span></a></li></ul></li><!-- end Tabs: [Tabs] 115061 --></ul></li><li id="menu-item-73292" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73292 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/" tabindex="0" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Opinion</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-73292 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width"  ><!-- begin Tabs: [Tabs] 115076 --><li id="menu-item-115076" class="ubermenu-tabs menu-item-115076 ubermenu-item-level-1 ubermenu-column ubermenu-column-full ubermenu-tab-layout-left"><ul  class="ubermenu-tabs-group ubermenu-column ubermenu-column-1-5 ubermenu-submenu ubermenu-submenu-id-115076 ubermenu-submenu-type-auto ubermenu-submenu-type-tabs-group"  ><li id="menu-item-115126" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-115126 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/ask_paul/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Ask Paul</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Paul McBride</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-115126 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115085] count[4] --><li id="menu-item-115085-post-115430" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115085 ubermenu-item-115085-post-115430 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/25/whats-the-proper-mag-timing-for-my-engine/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">What&#8217;s the proper mag timing for my engine?</span><div class="gan-uber-excerpt clearfix"><p>Q: Hi Paul, you helped me out a few years back regarding a question on an O-290 D2B and I really value your advice and opinions, so now I'll ask for your help once again.</p></div></a></li><li id="menu-item-115085-post-114564" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115085 ubermenu-item-115085-post-114564 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/06/tomahawk-buyer-plagued-with-engine-contamination/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Tomahawk buyer plagued with engine contamination</span><div class="gan-uber-excerpt clearfix"><p>Q: I bought a Tomahawk from someone I trusted. First oil change I discover very small needle-like pieces of aluminum in the filter, about a teaspoon worth. I ask the IA-rated seller about it.</p></div></a></li><li id="menu-item-115085-post-114377" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115085 ubermenu-item-115085-post-114377 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/13/whats-going-on-with-the-left-prop-on-my-piper-mojave/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">What&#8217;s going on with the left prop on my Piper Mojave?</span><div class="gan-uber-excerpt clearfix"><p>Q: I just bought a Piper Mojave. It has 1,200 hours on both engines. Pre-buy, including oil analysis, was good.

During a maiden flight, the left prop feathered on prop check.</p></div></a></li><li id="menu-item-115085-post-113378" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115085 ubermenu-item-115085-post-113378 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/10/04/what-should-i-do-about-rust-in-the-barrels-of-cylinders/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">What should I do about rust in the barrels of cylinders?</span><div class="gan-uber-excerpt clearfix"><p>Q: I read some of the material you have posted and was very impressed. I have a question about finding rust in the barrels of the cylinders.

Here is the situation: A customer is looking to buy a Piper Lance II.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115085] --><li id="menu-item-115127" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115127 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/ask_paul/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Ask Paul</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Paul McBride</span></a></li></ul></li><li id="menu-item-85914" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-85914 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/human-factors/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Human Factors</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Jeffrey Madison</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-85914 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115086] count[4] --><li id="menu-item-115086-post-115489" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115086 ubermenu-item-115086-post-115489 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/13/human-factors-self-inflicted/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Human Factors: Self-inflicted</span><div class="gan-uber-excerpt clearfix"><p>Last year I gifted my readers with stories of men and women pilots who acted heroically, and lived to tell about it.

This holiday season I’m going in a different direction.</p></div></a></li><li id="menu-item-115086-post-114765" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115086 ubermenu-item-115086-post-114765 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/19/ditching/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Ditching</span><div class="gan-uber-excerpt clearfix"><p>My last column, “Asleep at the Yoke,” included a report about a Piper Seneca pilot who had to ditch his airplane in the Gulf of Mexico. The thought of having to ditch an aircraft intrigued me, especially when I realized there is a different psychology to the act of ditching vs.</p></div></a></li><li id="menu-item-115086-post-113833" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115086 ubermenu-item-115086-post-113833 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/10/19/asleep-at-the-yoke/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Asleep at the yoke</span><div class="gan-uber-excerpt clearfix"><p>Falling asleep while flying is something I’ve never done. I remember reading about a flight crew who did, overflying their Hawaiian island destination. I wondered what those two pilots felt in that moment when they both suddenly awoke with land and the airport well behind them.</p></div></a></li><li id="menu-item-115086-post-112871" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115086 ubermenu-item-115086-post-112871 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/09/28/consideration-or-the-lack-of-it/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Consideration — or the lack of it</span><div class="gan-uber-excerpt clearfix"><p>We were on an out and back — Dulles to Newark, Newark to Dulles. Our assigned aircraft had just come out of maintenance. The captain flew the Newark leg. No issues.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115086] --><li id="menu-item-115094" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115094 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/human-factors/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Human Factors</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Jeffrey Madison</span></a></li></ul></li><li id="menu-item-84445" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-84445 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/letters/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Letters</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-84445 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115087] count[4] --><li id="menu-item-115087-post-91549" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115087 ubermenu-item-115087-post-91549 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2015/01/26/letter-dismantle-the-faas-involvement-in-medical-certification/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Letter: Dismantle the FAA’s involvement in medical certification?</span><div class="gan-uber-excerpt clearfix"><p>By Jim Posner, Poulsbo, Wash.

I have long thought that the FAA should NOT be in the medical certification business, at least for Part 91 operations.  Ever since my denial – despite letters from my doctors specifically stating that I am good to go – I have tried to understand why they should consider themselves more qualified to determine my fitness to fly than my own experts.  </p></div></a></li><li id="menu-item-115087-post-80256" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115087 ubermenu-item-115087-post-80256 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2013/07/03/eaa-youre-absolutely-right-its-complicated/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">EAA: &#8216;You&#8217;re absolutely right – it&#8217;s complicated&#8217;</span><div class="gan-uber-excerpt clearfix"><p>By Dick Knapinski, EAA Communications

I had the opportunity to read your column regarding the AirVenture ATC fees being assessed by the FAA. You’re absolutely right – it’s complicated.

There are some significant differences in your comparison between the FAA and the Oshkosh Police Department, and other points to consider as well, however:


	As some commenters mentioned, GA has already paid for FAA’s services through fuel taxes.</p></div></a></li><li id="menu-item-115087-post-65193" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115087 ubermenu-item-115087-post-65193 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2012/06/24/the-closing-of-mattituck/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">The closing of Mattituck</span><div class="gan-uber-excerpt clearfix"><p>LETTER TO THE EDITOR: I believe it was in 2003 that my brother told me about a program called the Mattituck Engine Workshop sponsored, as you can guess, by Teledyne Mattituck Services.</p></div></a></li><li id="menu-item-115087-post-38542" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115087 ubermenu-item-115087-post-38542 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2011/03/28/letter-volunteer-pilot-safety-stand-down-a-success/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Letter: Volunteer Pilot Safety Stand Down a success</span><div class="gan-uber-excerpt clearfix"><p>By Lindy Kirkland, President, The Air Care Alliance

First, let me say a big thank you for helping make the Volunteer Pilot Safety Stand Down (Sit up?) a big success.  All the comments I heard from pilots attending were very positive and encouraging.  </p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115087] --><li id="menu-item-115095" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115095 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/letters/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Letters</span></a></li></ul></li><li id="menu-item-115124" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-115124 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/of-wings-things/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Of Wings &#038; Things</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Frederick Johnsen</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-115124 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115088] count[4] --><li id="menu-item-115088-post-115567" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115088 ubermenu-item-115088-post-115567 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/28/no-pilot-no-problem/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">No pilot? No problem!</span><div class="gan-uber-excerpt clearfix"><p>An age-old component of aviation has been the pilot-in-the-loop. A pilot brings sophisticated human faculties to bear in solving problems of flight and making judgments on proper actions.

But sometimes, the presence of a pilot can be detrimental — to the pilot.</p></div></a></li><li id="menu-item-115088-post-115293" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115088 ubermenu-item-115088-post-115293 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/04/game-changing-fokkers-served-on-both-sides-of-the-atlantic/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Game-changing Fokkers served on both sides of the Atlantic</span><div class="gan-uber-excerpt clearfix"><p>When Anthony Fokker’s team introduced the futuristic Fokker D.VII biplane fighter to Germany in 1918, its welded steel tube fuselage and wings with less external bracing and rigging were a game-changer.</p></div></a></li><li id="menu-item-115088-post-114289" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115088 ubermenu-item-115088-post-114289 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/10/29/the-art-of-naming-aircraft/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">The art of naming aircraft</span><div class="gan-uber-excerpt clearfix"><p>Aircraft manufacturers and users have a penchant for picking names for their machines. Sometimes, a name is so good or so universally associated with a manufacturer that it gets recycled on a new design.</p></div></a></li><li id="menu-item-115088-post-113283" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115088 ubermenu-item-115088-post-113283 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/10/01/aerial-ambulances/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">How airplanes became aerial ambulances</span><div class="gan-uber-excerpt clearfix"><p>If World War I showed the nations of the world how the airplane could vault over ground emplacements to strike at an enemy, the combatants also came to appreciate the efficacy of using aircraft as ambulances to surmount obstacles and save precious time flying away from the fray.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115088] --><li id="menu-item-115125" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115125 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/of-wings-things/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Of Wings &#038; Things</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Frederick Johnsen</span></a></li></ul></li><li id="menu-item-115120" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-115120 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/politics-for-pilots/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Politics for Pilots</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Jamie Beckett</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-115120 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115089] count[4] --><li id="menu-item-115089-post-116018" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115089 ubermenu-item-115089-post-116018 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/02/a-centurys-passion-lost-and-found/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">A century&#8217;s passion lost and found</span><div class="gan-uber-excerpt clearfix"><p>Because I'm a bit weird, I found myself reading through a stack of newspapers from the early 20th Century recently. In those pages I found something that I hadn't seen in a while, something almost foreign to the American public in our current time.</p></div></a></li><li id="menu-item-115089-post-115942" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115089 ubermenu-item-115089-post-115942 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/26/dream-differently/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Dream differently</span><div class="gan-uber-excerpt clearfix"><p>If you're a pilot, you've got goals. That's just the way it is.

Maybe it's the fact that we have goals that lead us to this life where we have it so good.</p></div></a></li><li id="menu-item-115089-post-115821" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115089 ubermenu-item-115089-post-115821 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/19/all-i-want-for-christmas-revisited/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">All I want for Christmas, revisited</span><div class="gan-uber-excerpt clearfix"><p>Since childhood I've experienced an onslaught of marketing messages that focus on a single, classic, opening to a sentence. “All I want for Christmas...” I suspect you've experienced something similar.

At this slightly later stage of life (I tend to doubt any adolescents are reading this page) it might be time to revisit that idea.</p></div></a></li><li id="menu-item-115089-post-115667" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115089 ubermenu-item-115089-post-115667 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/12/the-importance-of-a-good-couch/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">The importance of a good couch</span><div class="gan-uber-excerpt clearfix"><p>In the back of my hangar sits the skeleton of a 1949 Piper PA-16 Clipper. It hasn't flown in many years. That's kind of sad. Hopefully, somebody will take on the task of restoring it to its former glory one day and it will become airborne again.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115089] --><li id="menu-item-115121" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115121 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/politics-for-pilots/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Politics for Pilots</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Jamie Beckett</span></a></li></ul></li><li id="menu-item-115122" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-115122 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/splog/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Splog</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Dan Johnson</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-115122 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115090] count[4] --><li id="menu-item-115090-post-115172" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115090 ubermenu-item-115090-post-115172 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/26/affordable-taildraggers-you-can-fly-with-little-fear/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Affordable taildraggers you can fly with little fear</span><div class="gan-uber-excerpt clearfix"><p>Have you heard of the dreaded ground loop? If you’ve ever contemplated flying a taildragger, a fellow pilot probably warned you about it.

If you’ve shied away from taildraggers as they sound difficult or fearsome, I recommend you learn more about Kolb Aircraft as it has some very affordable taildraggers that you can fly with little fear.</p></div></a></li><li id="menu-item-115090-post-114478" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115090 ubermenu-item-115090-post-114478 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/08/the-triumph-of-lsa/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">The triumph of LSA</span><div class="gan-uber-excerpt clearfix"><p>In barely over a decade, Light-Sport Aircraft have had an enormous impact on the world of aviation.

Is that too strong a statement? “Where are all these LSA,” you might ask?</p></div></a></li><li id="menu-item-115090-post-113606" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115090 ubermenu-item-115090-post-113606 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/10/08/big-achievements-by-a-small-manufacturer/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Big achievements by a small manufacturer</span><div class="gan-uber-excerpt clearfix"><p>“It simply won’t work,” say too many pilots. “You cannot run a business making only 50 airplanes a year. To build good, safe airplanes, you must operate a large enterprise.”

If you are one of those naysayers, are you sure about that?</p></div></a></li><li id="menu-item-115090-post-112702" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115090 ubermenu-item-115090-post-112702 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/08/31/atol-triphibian-for-sky-sea-or-snow/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Atol triphibian for sky, sea, or snow</span><div class="gan-uber-excerpt clearfix"><p>To many observers, the development of Light-Sport Aircraft seaplanes is fast-paced, inventive, and intriguing. You may have read about entries from the USA, Europe, or New Zealand. How about Finland?

“Finland has 188,000 lakes,” said Anssi Rekula, cofounder and sales director for Atol Avion, producer of the Atol LSA seaplane.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115090] --><li id="menu-item-115123" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115123 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/splog/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Splog</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Dan Johnson</span></a></li></ul></li><li id="menu-item-115128" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-115128 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/touch-go/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Touch &#038; Go</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Ben Sclair</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-115128 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115091] count[4] --><li id="menu-item-115091-post-116125" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115091 ubermenu-item-115091-post-116125 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/01/04/no-more-zero-days/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">No more zero days</span><div class="gan-uber-excerpt clearfix"><p>New year, new calendar, clean slate. Turning over a calendar seems to create in many of us the desire to do — and be — better.

Sadly, all too soon, we fall back into our regular ruts and habits.</p></div></a></li><li id="menu-item-115091-post-115684" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115091 ubermenu-item-115091-post-115684 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/20/are-you-dripping-fuel-do-you-know-where-your-log-books-are/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Are you dripping fuel? Do you know where your log books are?</span><div class="gan-uber-excerpt clearfix"><p>When I sit back and look at the world, I find it a fascinating place. For me, the most interesting details relate to people. Specifically, their actions and reactions.

If we slow down enough, there are a great many lessons to be learned from our fellow citizens of earth.</p></div></a></li><li id="menu-item-115091-post-115398" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115091 ubermenu-item-115091-post-115398 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/30/medicine-has-been-my-life-but-flying-is-my-passion/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">&#8216;Medicine has been my life, but flying is my passion&#8217;</span><div class="gan-uber-excerpt clearfix"><p>I believe there are multiple paths in life. Whether the topic is spiritual, technical, flying, driving or any other matters not. There are multiple ways to accomplish nearly anything. When it comes to flying, the paths to aviation and within aviation are myriad.</p></div></a></li><li id="menu-item-115091-post-114882" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115091 ubermenu-item-115091-post-114882 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/09/hangar-flying-is-just-what-the-cfi-ordered-for-those-dark-winter-nights/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Hangar Flying is just what the CFI ordered for those dark winter nights</span><div class="gan-uber-excerpt clearfix"><p>It seems like only yesterday my family and I were lounging in Hawaii soaking up the sun. It was July. Today, we’re starting to plan for Thanksgiving and beyond. Where has the time, and the Hawaiian sunshine, gone?</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115091] --><li id="menu-item-115129" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115129 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/touch-go/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Touch &#038; Go</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Ben Sclair</span></a></li></ul></li><li id="menu-item-115119" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-115119 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/vissers-voice/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Visser&#8217;s Voice</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Ben Visser</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-115119 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115092] count[4] --><li id="menu-item-115092-post-115577" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115092 ubermenu-item-115092-post-115577 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/12/10/why-is-lead-needed-during-engine-break-in/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Why is lead needed during engine break-in?</span><div class="gan-uber-excerpt clearfix"><p>In a past column I gave some background on what happens during break-in of a new or overhauled aircraft engine. Since then I have received numerous questions about why leaded fuel is needed during break-in.</p></div></a></li><li id="menu-item-115092-post-114788" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115092 ubermenu-item-115092-post-114788 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/11/23/all-plastics-are-not-created-equal/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">All plastics are not created equal</span><div class="gan-uber-excerpt clearfix"><p>In a recent email, a pilot related a problem he had with his aircraft: He needed to drain the fuel tanks so that he could repair the wing.

He drained the 100LL out of the tanks into two plastic drums.</p></div></a></li><li id="menu-item-115092-post-112911" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115092 ubermenu-item-115092-post-112911 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/10/25/tips-to-break-in-your-new-engine/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Tips to break-in your new engine</span><div class="gan-uber-excerpt clearfix"><p>In my last column, Breaking in a new engine in the Aug. 24 issue, I discussed the mechanics of breaking in an engine. In this column I will discuss some of the steps every pilot should take during break-in.</p></div></a></li><li id="menu-item-115092-post-113902" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115092 ubermenu-item-115092-post-113902 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2017/10/18/buying-a-used-fuel-tank-to-store-100ll/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Buying a used fuel tank to store 100LL</span><div class="gan-uber-excerpt clearfix"><p>I recently received an email from a pilot who lives in a remote area where 100LL is not readily available.

He was thinking about buying a used tank that had been storing #2 diesel fuel.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115092] --><li id="menu-item-115118" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115118 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/vissers-voice/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Read All Visser&#8217;s Voice</span><span class="ubermenu-target-divider"> – </span><span class="ubermenu-target-description ubermenu-target-text">Ben Visser</span></a></li></ul></li></ul></li><!-- end Tabs: [Tabs] 115076 --></ul></li><li id="menu-item-77967" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-77967 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/calendar/" tabindex="0" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Events</span></a></li><li id="menu-item-79146" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-item-79146 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/classifieds/" tabindex="0" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Classifieds</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-79146 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-left_edge_item"  ><li id="menu-item-103718" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-103718 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-natural" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/classifieds/place-classified-ad/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Place Classified Ad</span></a></li></ul></li><li id="menu-item-103233" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-103233 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/aviation-job-search/" tabindex="0" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Aviation Jobs</span></a></li><li id="menu-item-115101" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-115101 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="#" tabindex="0" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">More</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-115101 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-left_edge_item"  ><li id="menu-item-115104" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115104 ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-8" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/about/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">About</span></a></li><li id="menu-item-115109" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-115109 ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-3 ubermenu-has-submenu-stack" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="#" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">How Do I</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-115109 ubermenu-submenu-type-auto ubermenu-submenu-type-stack"  ><li id="menu-item-115105" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115105 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/advertise/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Advertise</span></a></li><li id="menu-item-115106" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115106 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/contact/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Contact Us</span></a></li><li id="menu-item-115107" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115107 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/writers-guidelines/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Writer&#8217;s Guidelines</span></a></li><li id="menu-item-115108" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115108 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/photographers-guidelines/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Photographer&#8217;s Guidelines</span></a></li></ul></li><li id="menu-item-115182" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-115182 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-stack" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="#" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Digital Editions</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-115182 ubermenu-submenu-type-auto ubermenu-submenu-type-stack"  ><li id="menu-item-115183" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115183 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/general-aviation-news-digital-edition/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">General Aviation News</span></a></li><li id="menu-item-115184" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115184 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/sun-n-fun-today/" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">SUN ’n FUN Today</span></a></li></ul></li></ul></li><li id="menu-item-115185" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115185 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/cs/" tabindex="0" itemprop="url"><span class="ubermenu-target-title ubermenu-target-text">Subscribe</span></a></li></ul></nav>
<!-- End UberMenu -->
</div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-116165 post type-post status-publish format-standard has-post-thumbnail category-products tag-aviation-news tag-general-aviation-2 entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Kaman introduces Advanced Memory and Data Exchange Universal System</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-01-05T07:46:55+00:00">January 5, 2018</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://generalaviationnews.com/author/ganstaff/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">General Aviation News Staff</span></a></span> <span class="entry-comments-link"><a href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p>The Memory Division of <a href="http://www.kamanmemory.com" target="_blank" rel="noopener">Kaman Precision Products</a> has introduced the AMADEUS — the Advanced Memory and Data Exchange Universal System.</p>
<p>The AMADEUS includes the Model 9740 Multi-Port data transfer unit, which includes four removable memory cards (RMC) and a mini-Ground Station Adapter (GSA).<span id="more-116165"></span></p>
<p><img data-attachment-id="116166" data-permalink="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/kaman-amadeus/" data-orig-file="https://generalaviationnews.com/wp-content/uploads/2018/01/Kaman-AMADEUS.jpg" data-orig-size="1200,795" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark II&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1502978940&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;35&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.0166666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Kaman-AMADEUS" data-image-description="" data-medium-file="https://generalaviationnews.com/wp-content/uploads/2018/01/Kaman-AMADEUS-300x199.jpg" data-large-file="https://generalaviationnews.com/wp-content/uploads/2018/01/Kaman-AMADEUS-1200x795.jpg" class="aligncenter size-full wp-image-116166" src="http://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2018/01/Kaman-AMADEUS.jpg" alt="" width="1200" height="795" srcset="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2018/01/Kaman-AMADEUS.jpg 1200w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2018/01/Kaman-AMADEUS-125x83.jpg 125w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2018/01/Kaman-AMADEUS-300x199.jpg 300w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2018/01/Kaman-AMADEUS-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>The Model 9740 provides simultaneous data interface over 10GB Ethernet, Mil-Std 1553, RS-232/422, as well as options to record multiple SMPTE 292 and NTSC (RS-170) video/audio channels.</p>
<p>Each Kaman RMC boasts a capacity of 2TB with AES 256 encrypted data-at-rest. This small card is packaged in a hermetically sealed stainless steel case and moves data at blinding speeds, company officials say.</p>
<p>The pocket-sized GSA facilitates expeditionary operations and enables the operator to connect with virtually any computer via USB 3.0 to rapidly exchange pre-and post-mission data, officials explain.</p>
<p>AMADEUS is engineered to align with Future Airborne Capability Environment (FACE) and perform in the harshest military, aerospace, and industrial environments.</p>
<span id="tve_leads_end_content" style="display: block; visibility: hidden; border: 1px solid transparent;"></span><div class='ctx-subscribe-container ctx-personalization-container ctx_default_placement ctx-clearfix'></div><div class='ctx-social-container ctx_default_placement ctx-clearfix'></div><div class='ctx-module-container ctx_default_placement ctx-clearfix'></div><div class="tve-leads-post-footer tve-tl-anim tve-leads-track-post_footer-5 tl-anim-instant"><div class="tl-style" id="tve_tcb2_set-021" data-state="5"><style type="text/css" class="tve_custom_style">@import url("//fonts.googleapis.com/css?family=Roboto:400,500,900,300,700&subset=latin");@media (min-width: 300px){[data-css="tve-u-15ee46f54a3"] { font-weight: 400 !important; font-family: Roboto !important; }#tve_editor [data-css="tve-u-7359aeb9c7b3407"]:hover button { background-color: rgb(7, 133, 115) !important; }#tve_editor [data-css="tve-u-7359aeb9c7b32ea"]:hover input { color: rgb(0, 109, 94); background-color: rgb(159, 202, 196) !important; }#tve_editor [data-css="tve-u-7359aeb9c7b3348"] > :first-child { color: rgb(216, 216, 216); }[data-css="tve-u-7359aeb9c7b311f"] { margin-bottom: 20px !important; }[data-css="tve-u-7359aeb9c7b2f43"] { padding-top: 0px !important; padding-bottom: 0px !important; }[data-css="tve-u-7359aeb9c7b2ee5"] { margin-top: 10px !important; margin-bottom: 20px !important; }[data-css="tve-u-7359aeb9c7b322b"] { margin-top: 0px !important; margin-bottom: 0px !important; }[data-css="tve-u-7359aeb9c7b2e7b"] { overflow: hidden; background-color: rgb(42, 56, 115) !important; border-radius: 10px !important; padding: 20px !important; }#tve_editor [data-css="tve-u-7359aeb9c7b3407"] button { font-size: 22px; line-height: 30px; font-family: Roboto; border-radius: 5px; overflow: hidden; border: none; background-color: rgb(0, 109, 94) !important; font-weight: bold !important; }#tve_editor [data-css="tve-u-7359aeb9c7b32ea"] input { line-height: 28px; color: rgb(51, 51, 51); font-family: Roboto; font-weight: 300; border: none; border-radius: 5px; overflow: hidden; background-image: none !important; padding: 14px 18px !important; }[data-css="tve-u-7359aeb9c7b31cd"] { line-height: 27px !important; }#tve_editor [data-css="tve-u-7359aeb9c7b31cd"] { font-family: Roboto; font-weight: 300; font-size: 18px !important; color: rgb(255, 255, 255) !important; }[data-css="tve-u-7359aeb9c7b3172"] strong { font-weight: 500; }[data-css="tve-u-7359aeb9c7b3172"] { line-height: 40px !important; }#tve_editor [data-css="tve-u-7359aeb9c7b3172"] { font-family: Roboto; font-weight: 300; color: rgb(255, 255, 255) !important; font-size: 36px !important; }[data-css="tve-u-7359aeb9c7b33a8"] { max-width: 30%; }[data-css="tve-u-7359aeb9c7b328c"] { max-width: 70%; }[data-css="tve-u-7359aeb9c7b305d"] { max-width: 75%; }[data-css="tve-u-7359aeb9c7b2fa1"] { max-width: 25%; }[data-css="tve-u-7359aeb9c7b2ffe"] { float: none; margin-left: auto; margin-right: auto; width: 155px; margin-top: 0px !important; margin-bottom: 0px !important; }}@media (max-width: 767px){[data-css="tve-u-7359aeb9c7b2e7b"] { padding: 14px !important; }[data-css="tve-u-7359aeb9c7b30bb"] { text-align: center; }[data-css="tve-u-7359aeb9c7b3172"] { line-height: 1.2em !important; }#tve_editor [data-css="tve-u-7359aeb9c7b3172"] { font-size: 28px !important; }[data-css="tve-u-7359aeb9c7b2ffe"] { width: 90px; margin-bottom: 10px !important; }}</style><style type="text/css" class="tve_user_custom_style">.tve-leads-conversion-object .thrv_heading h1,.tve-leads-conversion-object .thrv_heading h2,.tve-leads-conversion-object .thrv_heading h3{margin:0;padding:0}.tve-leads-conversion-object .thrv_text_element p,.tve-leads-conversion-object .thrv_text_element h1,.tve-leads-conversion-object .thrv_text_element h2,.tve-leads-conversion-object .thrv_text_element h3{margin:0}</style><div class="tve-leads-conversion-object" data-tl-type="post_footer"><div class="tve_flt"><div id="tve_editor" class="tve_shortcode_editor"><div class="thrv-leads-form-box tve_no_drag tve_no_icons thrv_wrapper tve_editor_main_content thrv-leads-in-content tve_empty_dropzone" style="" data-css="tve-u-7359aeb9c7b2e7b"><div class="thrv_wrapper thrv-columns" style="" data-css="tve-u-7359aeb9c7b2ee5"><div class="tcb-flex-row tcb-resized tcb--cols--2" data-css="tve-u-7359aeb9c7b2f43"><div class="tcb-flex-col" data-css="tve-u-7359aeb9c7b2fa1" style=""><div class="tcb-col tve_empty_dropzone"><div class="thrv_wrapper tve_image_caption" data-css="tve-u-7359aeb9c7b2ffe" style=""><span class="tve_image_frame" style="width: 100%;"><img class="tve_image wp-image-2421" alt="" width="155" height="155" title="set_21_icon" data-id="2421" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/tve_leads_templates/post_footer/tcb2_set-021/images/set_21_icon.png" style="width: 100%;" scale="0"></span></div></div></div><div class="tcb-flex-col" data-css="tve-u-7359aeb9c7b305d" style=""><div class="tcb-col tve_empty_dropzone" style="" data-css="tve-u-7359aeb9c7b30bb"><div class="thrv_wrapper thrv_text_element tve_empty_dropzone" style="" data-css="tve-u-7359aeb9c7b311f"><p data-css="tve-u-7359aeb9c7b3172" data-default="Enter your text here..."><strong>Be a better informed pilot.</strong></p></div><div class="thrv_wrapper thrv_text_element tve_empty_dropzone" style=""><p data-css="tve-u-7359aeb9c7b31cd" data-default="Enter your text here..."><span data-css="tve-u-15ee46f54a3" style="font-weight: 400; font-family: Roboto;">Join over 110,000 readers each month and get real-world news and information direct to your inbox, each day.</span></p></div></div></div></div></div><div class="thrv_wrapper thrv_lead_generation Better Informed Pilot" data-connection="api" style="" data-css="tve-u-7359aeb9c7b322b"><input type="hidden" class="tve-lg-err-msg" value="{&quot;email&quot;:&quot;Email address invalid&quot;,&quot;phone&quot;:&quot;Phone number invalid&quot;,&quot;password&quot;:&quot;Password invalid&quot;,&quot;passwordmismatch&quot;:&quot;Password mismatch error&quot;,&quot;required&quot;:&quot;Required field missing&quot;}">
<div class="thrv_lead_generation_container tve_clearfix">
<form action="#" method="post" novalidate="novalidate">
<div class="tve_lead_generated_inputs_container tve_clearfix tve_empty_dropzone">
<div class="thrv_wrapper thrv-columns"><div class="tcb-flex-row tcb--cols--2 tcb-resized"><div class="tcb-flex-col" data-css="tve-u-7359aeb9c7b328c" style=""><div class="tcb-col tve_empty_dropzone"><div class="tve_lg_input_container tve_lg_input tcb-icon-display tve_empty_dropzone" data-css="tve-u-7359aeb9c7b32ea"><div class="thrv_wrapper thrv_icon" style="" data-css="tve-u-7359aeb9c7b3348"><svg class="tcb-icon" viewBox="0 0 28 28" data-name="envelope">
<title>envelope</title>
<path d="M28 11.094v12.406c0 1.375-1.125 2.5-2.5 2.5h-23c-1.375 0-2.5-1.125-2.5-2.5v-12.406c0.469 0.516 1 0.969 1.578 1.359 2.594 1.766 5.219 3.531 7.766 5.391 1.313 0.969 2.938 2.156 4.641 2.156h0.031c1.703 0 3.328-1.188 4.641-2.156 2.547-1.844 5.172-3.625 7.781-5.391 0.562-0.391 1.094-0.844 1.563-1.359zM28 6.5c0 1.75-1.297 3.328-2.672 4.281-2.438 1.687-4.891 3.375-7.313 5.078-1.016 0.703-2.734 2.141-4 2.141h-0.031c-1.266 0-2.984-1.437-4-2.141-2.422-1.703-4.875-3.391-7.297-5.078-1.109-0.75-2.688-2.516-2.688-3.938 0-1.531 0.828-2.844 2.5-2.844h23c1.359 0 2.5 1.125 2.5 2.5z"></path>
</svg></div>
<input type="email" data-field="email" data-required="1" data-validation="email" name="email" placeholder="Email" data-placeholder="Email" class="" style="">
</div></div></div><div class="tcb-flex-col" data-css="tve-u-7359aeb9c7b33a8" style=""><div class="tcb-col tve_empty_dropzone"><div class="tve_lg_input_container tve_submit_container tve_lg_submit" data-css="tve-u-7359aeb9c7b3407">
<button type="submit" class="tve-froala" style="">Join for Free!</button>
</div></div></div></div></div>
</div>
<input type="hidden" name="__tcb_lg_fc" id="__tcb_lg_fc" value="YToxOntzOjE0OiJhY3RpdmVjYW1wYWlnbiI7czoxOiIxIjt9"><input id="_submit_option" type="hidden" name="_submit_option" value="message"><input id="__tcb_lg_msg" type="hidden" name="__tcb_lg_msg" value="YToyOntzOjU6ImVycm9yIjtzOjY6IkVycm9yISI7czo3OiJzdWNjZXNzIjtzOjM5OiJUaGFuayBZb3UuIEVuam95IFRoZSBQdWxzZSBvZiBBdmlhdGlvbi4iO30="><input type="hidden" id="activecampaign_form" class="tve-api-extra" name="activecampaign_form" value="0"><input type="hidden" id="activecampaign_tags" class="tve-api-extra" name="activecampaign_tags" value="Source - GAN Article Footer"></form>
</div>
</div></div></div></div></div></div></div><span class="ctx-article-root"><!-- --></span><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share This Story</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-116165" class="share-facebook sd-button share-icon no-text" href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-116165" class="share-twitter sd-button share-icon no-text" href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-116165" class="share-linkedin sd-button share-icon no-text" href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-116165" class="share-google-plus-1 sd-button share-icon no-text" href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://generalaviationnews.com/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div><footer class="entry-footer"></footer></article><div class="after-entry" class="widget-area"><section id="custom_html-7" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><!-- BEGIN ADVERTSERVE CODE -->
<div id="avp_zid_21">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_21', alias: '/', type: 'banner', zid: 21, pid: 0 });
</script>
</div>
<!-- END ADVERTSERVE CODE --></div></div></section>
</div><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/user-avatar/user-avatar-pic.php?src=https://generalaviationnews.com/wp-content/uploads/avatars/2456/1361899707-bpfull.jpg&#038;w=70&#038;id=2456&#038;random=1489699717" alt="" class=" avatar  avatar-70  photo user-2456-avatar" width="70" height="70" /><h4 class="author-box-title">About <span itemprop="name">General Aviation News Staff</span></h4><div class="author-box-content" itemprop="description"></div></section><div class="comment-policy-holder"><p>General Aviation News reserves the right to delete snarky, offensive or off-topic comments. See our <a href="/comment-policy/" target="_blank">Comment Policy</a> for more details.</p></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://generalaviationnews.com/wp-comments-post.php?wpe-comment-post=ganews" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='116165' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="30b5bff52b" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="134"/></p>			</form>
			</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://generalaviationnews.com/" role="search"><meta itemprop="target" content="https://generalaviationnews.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="custom_html-5" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><!-- BEGIN ADVERTSERVE CODE -->
<div id="avp_zid_17">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_17', alias: '/', type: 'banner', zid: 17, pid: 0 });
</script>
</div>
<!-- END ADVERTSERVE CODE --></div></div></section>
<section id="custom_html-6" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><!-- BEGIN ADVERTSERVE CODE -->
<div id="avp_zid_18">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_18', alias: '/', type: 'banner', zid: 18, pid: 0 });
</script>
</div>
<!-- END ADVERTSERVE CODE --></div></div></section>
<section id="js_jobs_widget-2" class="widget widget_js_jobs_widget"><div class="widget-wrap"><h4 class="widget-title widgettitle"></h4>
<div id="jobs-widget-holder"><h3>Aviation Jobs</h3><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=404219" >Helicopter Avionics Technician Part 145- Philadelphia, PA &raquo;</a><br /><span class="date-posted">Quanta Aviation Staffing - Philadelphia, Pennsylvania</span><br /><span class="date-posted">POSTED: 01/04/2018</span></p><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=426519" >Direct QC Inspector- Rockford, IL $1,000 Bonus &raquo;</a><br /><span class="date-posted">Quanta Aviation Staffing - Rockford, Illinois</span><br /><span class="date-posted">POSTED: 01/04/2018</span></p><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=432309" >Senior Cable  Harness Technician &raquo;</a><br /><span class="date-posted">Orbital ATK - Dulles, Virginia</span><br /><span class="date-posted">POSTED: 01/04/2018</span></p><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=432308" >Aviation Sales Person &raquo;</a><br /><span class="date-posted">Heli-Parts Nevada Inc. - Boulder City, Nevada</span><br /><span class="date-posted">POSTED: 01/04/2018</span></p><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=19894" >AP Mechanic &raquo;</a><br /><span class="date-posted">King Aerospace - El Paso, Texas</span><br /><span class="date-posted">POSTED: 01/04/2018</span></p><p style="text-align: center; "><a href="/aviation-job-search/" class="button">Search all jobs</a><p></div></div></section>
<section id="custom_html-4" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_19"><script type="text/javascript">
_avp.push({ tagid: 'avp_zid_19', alias: '/', type: 'banner', zid: 19, pid: 0 });
</script></div></div></div></section>
</aside></div></div><!-- BEGIN ADVERTSERVE CODE -->
<div id="avp_zid_22">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_22', alias: '/', type: 'banner', zid: 22, pid: 0 });
</script>
</div>
<!-- END ADVERTSERVE CODE --><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2018 &#x000B7; <a href="http://my.studiopress.com/themes/news/">News Pro Theme</a> on <a href="http://www.studiopress.com/">Genesis Framework</a> &#x000B7; <a href="http://wordpress.org/">WordPress</a> &#x000B7; <a href="https://generalaviationnews.com/wp-login.php">Log in</a></p></div></footer></div><script type="text/javascript">
		Contextly.ready('load', "wp\/widgets", function() {
		Contextly.WPSettings.setPostData(116165,{"ajax_nonce":"cb61908027"});Contextly.ready("widgets");	});
	</script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/generalaviationnews.com\/2018\/01\/05\/kaman-introduces-advanced-memory-and-data-exchange-universal-system\/":116165};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2018/01/05/kaman-introduces-advanced-memory-and-data-exchange-universal-system/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201801'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tve_frontend_options = {"is_editor_page":"","page_events":[],"is_single":"1","ajaxurl":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","social_fb_app_id":"","dash_url":"https:\/\/generalaviationnews.com\/wp-content\/plugins\/thrive-visual-editor\/thrive-dashboard","translations":{"Copy":"Copy"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-visual-editor/editor/js/dist/frontend.min.js?ver=2.0.16'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-leads/js/frontend.min.js?ver=2.0.17'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=4.9.1'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var tve_dash_front = {"ajaxurl":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","is_crawler":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-visual-editor/thrive-dashboard/js/dist/frontend.min.js?ver=2.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ubermenu_data = {"remove_conflicts":"on","reposition_on_load":"off","intent_delay":"300","intent_interval":"100","intent_threshold":"7","scrollto_offset":"50","scrollto_duration":"1000","responsive_breakpoint":"959","accessible":"on","retractor_display_strategy":"responsive","touch_off_close":"on","collapse_after_scroll":"on","v":"3.3.1","configurations":["main"],"ajax_url":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/generalaviationnews.com\/wp-content\/plugins\/ubermenu\/","disable_mobile":"off","prefix_boost":"","aria_role_navigation":"off","aria_expanded":"off","aria_hidden":"off","aria_controls":"","aria_responsive_toggle":"off","theme_locations":{"primary":"Primary Navigation Menu","secondary":"Secondary Navigation Menu"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/assets/js/ubermenu.min.js?ver=3.3.1'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","nonce":"a11842d1ed","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/generalaviationnews.com\/wp-login.php?redirect_to=https%3A%2F%2Fgeneralaviationnews.com%2F2018%2F01%2F05%2Fkaman-introduces-advanced-memory-and-data-exchange-universal-system%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20170209'></script>
<script async="async" type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=5.7'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type="text/javascript">/*<![CDATA[*/if ( !window.TL_Const ) var TL_Const={"security":"0d33283c12","ajax_url":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","forms":{"post_footer":{"_key":"5","trigger":"page_load","trigger_config":{},"form_type_id":113848,"main_group_id":113847,"active_test_id":""}},"action_conversion":"tve_leads_ajax_conversion","action_impression":"tve_leads_ajax_impression","ajax_load":0,"main_group_id":113847,"display_options":{"allowed_post_types":[],"flag_url_match":false},"custom_post_data":[],"current_screen":{"screen_type":4,"screen_id":116165},"ignored_fields":["email","_captcha_size","_captcha_theme","_captcha_type","_submit_option","_use_captcha","g-recaptcha-response","__tcb_lg_fc","__tcb_lg_msg","_state","_form_type","_error_message_option","_back_url","_submit_option","url","_asset_group","_asset_option","mailchimp_optin"]}/*]]> */</script><script type="text/javascript">var TL_Front = TL_Front || {}; TL_Front.impressions_data = TL_Front.impressions_data || {};TL_Front.impressions_data.post_footer = {"group_id":113847,"form_type_id":113848,"variation_key":"5","active_test_id":0,"output_js":true};</script><script type="text/javascript">
	(function ($) {
	$(function () {
		var event_data = {"form_id":"tve-leads-track-post_footer-5","form_type":"post_footer"};
		event_data.source = 'page_load';
		setTimeout(function () {
			ThriveGlobal.$j(TL_Front).trigger('showform.thriveleads', event_data);
			}, 200);
		});
	})
(ThriveGlobal.$j);
</script><script type='text/javascript' src='https://stats.wp.com/e-201801.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.7',blog:'35113008',post:'116165',tz:'-8',srv:'generalaviationnews.com'} ]);
	_stq.push([ 'clickTrackerInit', '35113008', '116165' ]);
</script>
</body></html>
