<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='contextly-page' id='contextly-page' content='{"title":"Aviation Day at KFMY","url":"https:\/\/generalaviationnews.com\/2019\/11\/14\/aviation-day-at-kfmy\/","pub_date":"2019-11-14 09:15:11","mod_date":"2019-11-14 07:47:39","type":"post","post_id":"130887","author_id":"2456","author_name":"General Aviation News Staff","author_display_name":"General Aviation News Staff","tags":["airport","Aviation News","General Aviation"],"categories":["News"],"image":"https:\/\/generalaviationnews.com\/wp-content\/uploads\/2019\/11\/Tico-Belle.jpg"}' />
<title>Aviation Day at KFMY</title>

<!-- This site is optimized with the Yoast SEO plugin v12.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Aviation Day at KFMY" />
<meta property="og:description" content="The free annual event will feature C-47 &quot;Tico Belle&quot; and the C-54 &quot;Spirit of Freedom.&quot;" />
<meta property="og:url" content="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/" />
<meta property="og:site_name" content="General Aviation News" />
<meta property="article:publisher" content="https://www.facebook.com/ganews/" />
<meta property="article:author" content="ganews" />
<meta property="article:tag" content="airport" />
<meta property="article:tag" content="Aviation News" />
<meta property="article:tag" content="General Aviation" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-11-14T17:15:11+00:00" />
<meta property="article:modified_time" content="2019-11-14T15:47:39+00:00" />
<meta property="og:updated_time" content="2019-11-14T15:47:39+00:00" />
<meta property="og:image" content="https://generalaviationnews.com/wp-content/uploads/2019/11/Tico-Belle.jpg" />
<meta property="og:image:secure_url" content="https://generalaviationnews.com/wp-content/uploads/2019/11/Tico-Belle.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="767" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The free annual event will feature C-47 &quot;Tico Belle&quot; and the C-54 &quot;Spirit of Freedom.&quot;" />
<meta name="twitter:title" content="Aviation Day at KFMY" />
<meta name="twitter:site" content="@genavnews" />
<meta name="twitter:image" content="https://generalaviationnews.com/wp-content/uploads/2019/11/Tico-Belle.jpg" />
<meta name="twitter:creator" content="@genavnews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://generalaviationnews.com/#organization","name":"General Aviation News","url":"https://generalaviationnews.com/","sameAs":["https://www.facebook.com/ganews/","https://www.linkedin.com/company/general-aviation-news/","https://twitter.com/genavnews"],"logo":{"@type":"ImageObject","@id":"https://generalaviationnews.com/#logo","url":"https://generalaviationnews.com/wp-content/uploads/2014/10/GAN1.jpg","width":260,"height":90,"caption":"General Aviation News"},"image":{"@id":"https://generalaviationnews.com/#logo"}},{"@type":"WebSite","@id":"https://generalaviationnews.com/#website","url":"https://generalaviationnews.com/","name":"General Aviation News","publisher":{"@id":"https://generalaviationnews.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://generalaviationnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/#primaryimage","url":"https://generalaviationnews.com/wp-content/uploads/2019/11/Tico-Belle.jpg","width":1200,"height":767},{"@type":"WebPage","@id":"https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/#webpage","url":"https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/","inLanguage":"en-US","name":"Aviation Day at KFMY","isPartOf":{"@id":"https://generalaviationnews.com/#website"},"primaryImageOfPage":{"@id":"https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/#primaryimage"},"datePublished":"2019-11-14T17:15:11+00:00","dateModified":"2019-11-14T15:47:39+00:00"},{"@type":"Article","@id":"https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/#article","isPartOf":{"@id":"https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/#webpage"},"author":{"@id":"https://generalaviationnews.com/#/schema/person/a8f16eafa25ef23db3cd50a3ec3bab24"},"headline":"Aviation Day at KFMY","datePublished":"2019-11-14T17:15:11+00:00","dateModified":"2019-11-14T15:47:39+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/#webpage"},"publisher":{"@id":"https://generalaviationnews.com/#organization"},"image":{"@id":"https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/#primaryimage"},"keywords":"airport,Aviation News,General Aviation","articleSection":"News"},{"@type":["Person"],"@id":"https://generalaviationnews.com/#/schema/person/a8f16eafa25ef23db3cd50a3ec3bab24","name":"General Aviation News Staff","image":{"@type":"ImageObject","@id":"https://generalaviationnews.com/#authorlogo","url":"https://secure.gravatar.com/avatar/94f0c36158e7322e751b920814ec4598?s=96&d=mm&r=g","caption":"General Aviation News Staff"},"sameAs":["ganews","https://twitter.com/genavnews"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel="amphtml" href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/amp/" /><meta name="generator" content="AMP for WP 0.9.98.14"/><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="General Aviation News &raquo; Feed" href="https://generalaviationnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="General Aviation News &raquo; Comments Feed" href="https://generalaviationnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="General Aviation News &raquo; Aviation Day at KFMY Comments Feed" href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/generalaviationnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='news-pro-theme-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='tve_style_family_tve_flt-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-visual-editor/editor/css/thrive_flat.css?ver=2.4.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='tve_leads_forms-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-leads/editor-layouts/css/frontend.css?ver=2.2.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='js-job-styles-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/gan-js-firm-jobs/css/js-jobs.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-style-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='footable-core-min-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/footable/css/footable.core.min.css?ver=0.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/pro/assets/css/ubermenu.min.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-white-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/pro/assets/css/skins/white.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-font-awesome-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/assets/css/fontawesome/css/font-awesome.min.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.9' type='text/css' media='all' />
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/gan-js-firm-jobs/js/js-jobs.js?ver=2.7'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/js/gan.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/footable/js/footable.min.js?ver=0.3.1'></script>
<link rel='https://api.w.org/' href='https://generalaviationnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://generalaviationnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://generalaviationnews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://generalaviationnews.com/?p=130887' />
<link rel="alternate" type="application/json+oembed" href="https://generalaviationnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgeneralaviationnews.com%2F2019%2F11%2F14%2Faviation-day-at-kfmy%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://generalaviationnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgeneralaviationnews.com%2F2019%2F11%2F14%2Faviation-day-at-kfmy%2F&#038;format=xml" />
<style type="text/css" id="tve_global_variables">:root{}</style>

<script type="text/javascript">
	(function (w, d, id, ns, s) {
		var c = w[ns] = w[ns] || {};
		if (!c.ready) {
			c.q = [];
			c.ready = function () {
				c.q.push(arguments);
			};
						c.ready.apply(c, ["expose",{"wp\/widgets":{"dependencies":["widgets"],"js":["https:\/\/assets.context.ly\/wp-plugin\/5.0.7\/js\/contextly-wordpress.js"],"foreign":true}}]);
						c.ready.apply(c, ["libraries",{"jquery":false}]);
						c.ready.apply(c, ["load","wp\/widgets"]);
					}

				if (!d.getElementById(id)) {
			var e = d.createElement(s);
			e.id = id;
			e.src = "https:\/\/assets.context.ly\/kit\/5.latest\/loader.js";
			var h = d.getElementsByTagName(s)[0];
			h.parentNode.insertBefore(e, h);
		}
			})(window, document, 'ctx-loader', 'Contextly', 'script');

	(function(c, ns){var v=c[ns]=c[ns]||{};v["appId"]="generalaviationnews";
	v["https"]=true;
	v["client"]={"client":"wp","version":"5.0.7"};
	})(Contextly,"overrides");
(function(c, ns){var v=c[ns]=c[ns]||{};v["ajax_url"]="https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php";
	})(Contextly,"wpdata");
</script>


<!-- This site uses the Open External Links in a New Window plugin v1.4 by WebFactory Ltd. Download it for free at https://wordpress.org/extend/plugins/open-external-links-in-a-new-window/ -->
<script type="text/javascript">//<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = '';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('generalaviationnews.com') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]></script>

<style id="ubermenu-custom-generated-css">
/** UberMenu Custom Menu Styles (Customizer) **/
/* main */
 .ubermenu-responsive-toggle-main, .ubermenu-main, .ubermenu-main .ubermenu-target, .ubermenu-main .ubermenu-nav .ubermenu-item-level-0 .ubermenu-target { font-family:Helvetica, Arial, sans-serif; }
 .ubermenu-main, .ubermenu-main .ubermenu-target, .ubermenu-main .ubermenu-nav .ubermenu-item-level-0 .ubermenu-target { font:bold 12px/24px Helvetica, Arial, sans-serif; }


/** UberMenu Custom Menu Item Styles (Menu Item Settings) **/
/* 116331 */ .ubermenu .ubermenu-item.ubermenu-item-116331 > .ubermenu-target,.ubermenu .ubermenu-item.ubermenu-item-116331 > .ubermenu-content-block,.ubermenu .ubermenu-item.ubermenu-item-116331.ubermenu-custom-content-padded { padding:5px; }

/* Status: Loaded from Transient */

</style><link rel="icon" href="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/images/favicon.ico" />
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-N9M565');</script>
<!-- End Google Tag Manager -->

<!-- BEGIN ADVERTSERVE CODE -->
<script type="text/javascript">
var _avp = _avp || [];
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript'; s.async = true; s.src = window.location.protocol + '//generalaviationnews.advertserve.com/js/libcode3.js';
  var x = document.getElementsByTagName('script')[0];
  x.parentNode.insertBefore(s, x);
})();
</script>
<!-- END ADVERTSERVE CODE -->

<meta name="msvalidate.01" content="6AFE84FD4FB3D235EEA8E3F0D49B96BB" />

<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=246286545395661&autoLogAppEvents=1"></script><style type="text/css">.site-title a { background: url(https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2014/10/GAN1.jpg) no-repeat !important; }</style>
<meta property="og:image" content="https://generalaviationnews.com/wp-content/uploads/2019/11/Tico-Belle.jpg"><meta property="og:image:width" content="1024"><meta property="og:image:height" content="768"><link rel="image_src" href="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Tico-Belle.jpg"><script type="text/javascript">/* FooTable init code */

var $FOOTABLE = $FOOTABLE || {};
(function( $FOOTABLE, $, undefined ) {

	jQuery.fn.attrAppendWithComma=function(a,b){var c;return this.each(function(){c=$(this),void 0!==c.attr(a)&&""!=c.attr(a)?c.attr(a,c.attr(a)+","+b):c.attr(a,b)})};jQuery.fn.footableAttr=function(a,b){return this.each(function(){var c=$(this);c.data("auto-columns")!==!1&&(c.find("thead th:gt("+a+")").attrAppendWithComma("data-hide","tablet"),c.find("thead th:gt("+b+")").attrAppendWithComma("data-hide","phone"))})},jQuery.fn.footableFilter=function(a){return this.each(function(){var b=$(this);b.data("filter")||b.data("filter")===!1||b.data("filter-text-only","true").before('<div class="footable-filter-container"><input placeholder="'+a+'" style="float:right" type="text" class="footable-filter" /></div>')})},jQuery.fn.footablePager=function(){return this.each(function(){var a=$(this);if(a.data("page")!==!1){var b=$('<tfoot class="hide-if-no-paging"><tr><td><div class="pagination pagination-centered"></div></td></tr></tfoot>');b.find("td").attr("colspan",a.find("thead th").length),a.find("tbody:last").after(b)}})};

	$FOOTABLE.init = function() {
		$(".footable")
			.footableAttr(4,1)
			.footable( { breakpoints: { phone: 320, tablet: 768 } });

	};
}( $FOOTABLE, jQuery ));

jQuery(function($) {
	$FOOTABLE.init();
});
</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
			<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.
Click the help icon above to learn more.
*/		</style>
		</head>
<body class="post-template-default single single-post postid-130887 single-format-standard custom-background custom-header header-image content-sidebar genesis-breadcrumbs-hidden"><!-- Google Tag Manager (noscript) --><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N9M565" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><!-- End Google Tag Manager (noscript) --><div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://generalaviationnews.com/">General Aviation News</a></p></div><div class="widget-area header-widget-area"><section id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_1">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_1', alias: '/', type: 'banner', zid: 1, pid: 0 });
</script>
</div></div></div></section>
</div><div id="gan-login-link"><a href="https://generalaviationnews.com/wp-login.php?redirect_to=https%3A%2F%2Fgeneralaviationnews.com%2F2019%2F11%2F14%2Faviation-day-at-kfmy%2F"><img src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/themes/news-pro/images/gan-login-link.png" /></a></div></div></header><nav class="nav-primary" aria-label="Main"><div class="wrap">
<!-- UberMenu [Configuration:main] [Theme Loc:primary] [Integration:auto] -->
<a class="ubermenu-responsive-toggle ubermenu-responsive-toggle-main ubermenu-skin-white ubermenu-loc-primary ubermenu-responsive-toggle-content-align-left ubermenu-responsive-toggle-align-full " data-ubermenu-target="ubermenu-main-3063-primary-2"><i class="fa fa-bars"></i>GENERAL AVIATION NEWS</a><nav id="ubermenu-main-3063-primary-2" class="ubermenu ubermenu-nojs ubermenu-main ubermenu-menu-3063 ubermenu-loc-primary ubermenu-responsive ubermenu-responsive-default ubermenu-responsive-collapse ubermenu-horizontal ubermenu-transition-slide ubermenu-trigger-hover_intent ubermenu-skin-white  ubermenu-bar-align-full ubermenu-items-align-left ubermenu-bound ubermenu-sub-indicators ubermenu-retractors-responsive"><ul id="ubermenu-nav-main-3063-primary" class="ubermenu-nav"><li id="menu-item-73290" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-current-post-ancestor ubermenu-current-menu-parent ubermenu-current-post-parent ubermenu-item-has-children ubermenu-item-73290 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">News</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-73290 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width"  ><!-- begin Tabs: [Tabs] 115061 --><li id="menu-item-115061" class="ubermenu-tabs menu-item-115061 ubermenu-item-level-1 ubermenu-column ubermenu-column-full ubermenu-tab-layout-left"><ul  class="ubermenu-tabs-group ubermenu-column ubermenu-column-1-5 ubermenu-submenu ubermenu-submenu-id-115061 ubermenu-submenu-type-auto ubermenu-submenu-type-tabs-group"  ><li id="menu-item-73294" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73294 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/accident-reports/"><span class="ubermenu-target-title ubermenu-target-text">Accidents</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-73294 ubermenu-submenu-type-tab-content-panel ubermenu-submenu-grid"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115066] count[4] --><li id="menu-item-115066-post-130393" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115066 ubermenu-item-115066-post-130393 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/14/n754t-cloud-jeffrey-propeller-separates-in-flight-ferrell-long-ez/"><span class="ubermenu-target-title ubermenu-target-text">Long EZ&#8217;s propeller separates in flight</span><div class="gan-uber-excerpt clearfix"><p>Probable cause: The in-flight separation of a portion of the propeller, which subsequently penetrated the right rudder, as a result of the failure of the bond line between two of the propeller’s wood layers. Contributing to the failure of the propeller was the </p></div></a></li><li id="menu-item-115066-post-130398" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115066 ubermenu-item-115066-post-130398 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/13/carb-ice-n10gj-piper-pa-28-180/"><span class="ubermenu-target-title ubermenu-target-text">Carb icing leads to forced landing in a field</span><div class="gan-uber-excerpt clearfix"><p>Probable cause: The total loss of engine power due to carburetor icing. </p></div></a></li><li id="menu-item-115066-post-130382" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115066 ubermenu-item-115066-post-130382 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/12/fuel-starvation-n3067h-ercoupe-415-cd/"><span class="ubermenu-target-title ubermenu-target-text">Fuel starvation leads to forced landing on a road</span><div class="gan-uber-excerpt clearfix"><p>Probable cause: The failure of the engine-driven fuel pump and the pilot's failure to identify the pump's failure, which resulted in a loss of engine power due to fuel starvation and a forced landing on a road, during which the airplane hit obstacles.</p></div></a></li><li id="menu-item-115066-post-130388" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115066 ubermenu-item-115066-post-130388 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/11/bird-n9678q-cessna-172m/"><span class="ubermenu-target-title ubermenu-target-text">Bird strikes Cessna 172 in flight</span><div class="gan-uber-excerpt clearfix"><p>Probable cause: An in-flight collision with a bird. </p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115066] --><li id="menu-item-115073" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-115073 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-full ubermenu-align-left" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only read-all-link" href="https://generalaviationnews.com/category/accident-reports/"><span class="ubermenu-target-title ubermenu-target-text">Read All Accident Articles</span></a></li></ul></li><li id="menu-item-124265" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-124265 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/aircraft-news"><span class="ubermenu-target-title ubermenu-target-text">Aircraft News</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-124265 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115067] count[4] --><li id="menu-item-115067-post-130715" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115067 ubermenu-item-115067-post-130715 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/06/faa-develops-plan-to-preserve-aircraft-owners-privacy-as-ads-b-becomes-mandatory/"><span class="ubermenu-target-title ubermenu-target-text">FAA develops plan to preserve aircraft owners privacy as ADS-B becomes mandatory</span><div class="gan-uber-excerpt clearfix"><p>Worries about privacy have kept some aircraft owners from equipping with ADS-B.</p></div></a></li><li id="menu-item-115067-post-130444" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115067 ubermenu-item-115067-post-130444 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/22/first-sling-built-in-u-s-takes-flight/"><span class="ubermenu-target-title ubermenu-target-text">First Sling built in U.S. takes flight</span><div class="gan-uber-excerpt clearfix"><p> "I’m a new pilot, so I wanted an airplane that would be simple and stable to fly, as well as get me where I wanted to go."</p></div></a></li><li id="menu-item-115067-post-127191" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115067 ubermenu-item-115067-post-127191 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/05/06/flightstar-teams-with-the-leather-institute-for-midwest-satellite-location/"><span class="ubermenu-target-title ubermenu-target-text">Flightstar teams with The Leather Institute for Midwest satellite location</span><div class="gan-uber-excerpt clearfix"><p>Flightstar Corporation, a maintenance, repair, and overhaul operation (MRO) at the University of Illinois-Willard Airport (KCMI) in Champaign, Illinois, has partnered with The Leather Institute to open a satellite location.







The Leather Institute, which repairs and restores leather, will begin operations from Flightstar's facility in mid-summer 2019.</p></div></a></li><li id="menu-item-115067-post-121932" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115067 ubermenu-item-115067-post-121932 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2018/09/21/astm-releases-new-standards-for-seaplanes/"><span class="ubermenu-target-title ubermenu-target-text">ASTM releases new standards for seaplanes</span><div class="gan-uber-excerpt clearfix"><p>ASTM is releasing new standards for seaplanes and floatplanes to help determine  appropriate water loads that occur during landing, taxiing, and takeoffs.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115067] --><li id="menu-item-124266" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-124266 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto ubermenu-align-left" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only read-all-link" href="https://generalaviationnews.com/tag/aircraft-news"><span class="ubermenu-target-title ubermenu-target-text">Read all Aircraft Articles</span></a></li></ul></li><li id="menu-item-124267" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-124267 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/airports"><span class="ubermenu-target-title ubermenu-target-text">Airports</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-124267 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115068] count[4] --><li id="menu-item-115068-post-130790" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115068 ubermenu-item-115068-post-130790 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/09/historic-maine-airfield-threatened/"><span class="ubermenu-target-title ubermenu-target-text">Historic Maine airfield threatened</span><div class="gan-uber-excerpt clearfix"><p>Other sites are more suited to the proposed solar generating plant, according to RAF officials.</p></div></a></li><li id="menu-item-115068-post-130688" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115068 ubermenu-item-115068-post-130688 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/05/faa-says-santa-monica-can-use-airport-revenue-to-shorten-runway/"><span class="ubermenu-target-title ubermenu-target-text">FAA says Santa Monica can use airport revenue to shorten runway</span><div class="gan-uber-excerpt clearfix"><p>“The FAA’s decision allows Santa Monica to continue its avowed agenda to make SMO as inhospitable as possible to aviation operators.,”</p></div></a></li><li id="menu-item-115068-post-130470" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115068 ubermenu-item-115068-post-130470 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/23/americas-amazing-airports/"><span class="ubermenu-target-title ubermenu-target-text">America&#8217;s Amazing Airports</span><div class="gan-uber-excerpt clearfix"><p>A gold mine of interesting airport history is found in the new book.</p></div></a></li><li id="menu-item-115068-post-130415" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115068 ubermenu-item-115068-post-130415 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/21/simulating-an-airplane-crash/"><span class="ubermenu-target-title ubermenu-target-text">Simulating an airplane crash</span><div class="gan-uber-excerpt clearfix"><p>To make the scenario as realistic as possible, officials used a burn prop to create an airplane fuselage with controlled flames. </p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115068] --><li id="menu-item-124268" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-124268 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only read-all-link" href="https://generalaviationnews.com/tag/airports"><span class="ubermenu-target-title ubermenu-target-text">Read All Airport Stories</span></a></li></ul></li><li id="menu-item-124271" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-124271 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/avionics"><span class="ubermenu-target-title ubermenu-target-text">Avionics &#038; Instruments</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-124271 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115069] count[4] --><li id="menu-item-115069-post-130831" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115069 ubermenu-item-115069-post-130831 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/11/garmin-adds-piper-models-to-gfc-500-autopilot-stc/"><span class="ubermenu-target-title ubermenu-target-text">Garmin adds Piper models to GFC 500 autopilot STC</span><div class="gan-uber-excerpt clearfix"><p>Added to the STC are the Piper PA-28 Models: 201T and 236 and the 
Piper PA-32 Models 260 and 300.</p></div></a></li><li id="menu-item-115069-post-130715" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115069 ubermenu-item-115069-post-130715 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/06/faa-develops-plan-to-preserve-aircraft-owners-privacy-as-ads-b-becomes-mandatory/"><span class="ubermenu-target-title ubermenu-target-text">FAA develops plan to preserve aircraft owners privacy as ADS-B becomes mandatory</span><div class="gan-uber-excerpt clearfix"><p>Worries about privacy have kept some aircraft owners from equipping with ADS-B.</p></div></a></li><li id="menu-item-115069-post-130672" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115069 ubermenu-item-115069-post-130672 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/04/ps-engineering-upgrades-audio-panel/"><span class="ubermenu-target-title ubermenu-target-text">PS Engineering upgrades audio panel</span><div class="gan-uber-excerpt clearfix"><p>"The PAR200B meets the needs of those whose mission is flying mostly VFR."</p></div></a></li><li id="menu-item-115069-post-130628" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115069 ubermenu-item-115069-post-130628 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/30/garmin-introduces-autoland/"><span class="ubermenu-target-title ubermenu-target-text">Garmin introduces Autoland</span><div class="gan-uber-excerpt clearfix"><p>In the event of an emergency, Autoland determines the optimal airport and runway, taking into account factors such as weather, terrain, obstacles, and aircraft performance statistics.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115069] --><li id="menu-item-124272" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-124272 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only read-all-link" href="https://generalaviationnews.com/tag/avionics"><span class="ubermenu-target-title ubermenu-target-text">Read all Avionics &#038; Instrument stories</span></a></li></ul></li><li id="menu-item-124269" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-124269 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/flight-training"><span class="ubermenu-target-title ubermenu-target-text">Flight Training</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-124269 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115070] count[4] --><li id="menu-item-115070-post-130869" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115070 ubermenu-item-115070-post-130869 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/13/king-schools-introduces-interactive-garmin-gtn-650-750-video-course/"><span class="ubermenu-target-title ubermenu-target-text">King Schools introduces interactive Garmin GTN 650/750 video course</span><div class="gan-uber-excerpt clearfix"><p>The new course is "much more than a manual or simple how-to video," company officials say.</p></div></a></li><li id="menu-item-115070-post-130487" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115070 ubermenu-item-115070-post-130487 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/07/the-flying-grants/"><span class="ubermenu-target-title ubermenu-target-text">The Flying Grants</span><div class="gan-uber-excerpt clearfix"><p>A daughter's dream to fly rekindles her father's dream.</p></div></a></li><li id="menu-item-115070-post-130712" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115070 ubermenu-item-115070-post-130712 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/07/airline-offers-flight-education-grants/"><span class="ubermenu-target-title ubermenu-target-text">Airline offers flight education grants</span><div class="gan-uber-excerpt clearfix"><p>This year the grant program is focusing on schools that use AOPA's high school aviation STEM curriculum.</p></div></a></li><li id="menu-item-115070-post-130614" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115070 ubermenu-item-115070-post-130614 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/30/performance-aircraft-opens-new-flight-training-facility-at-klnk/"><span class="ubermenu-target-title ubermenu-target-text">Performance Aircraft opens new flight training facility at KLNK</span><div class="gan-uber-excerpt clearfix"><p>Facilities include a a new hangar that houses the school's fleet of training aircraft, which includes Cirrus, Cessna and Piper Aircraft.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115070] --><li id="menu-item-124270" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-124270 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only read-all-link" href="https://generalaviationnews.com/tag/flight-training"><span class="ubermenu-target-title ubermenu-target-text">Read all Flight Training Articles</span></a></li></ul></li><li id="menu-item-115060" class="ubermenu-tab ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-current-post-ancestor ubermenu-current-menu-parent ubermenu-current-post-parent ubermenu-item-115060 ubermenu-item-auto ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/news/"><span class="ubermenu-target-title ubermenu-target-text">All News</span></a></li></ul></li><!-- end Tabs: [Tabs] 115061 --></ul></li><li id="menu-item-73292" class="ubermenu-item ubermenu-item-type-taxonomy ubermenu-item-object-category ubermenu-item-has-children ubermenu-item-73292 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/category/opinion/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Opinion</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-73292 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width"  ><!-- begin Tabs: [Tabs] 115076 --><li id="menu-item-115076" class="ubermenu-tabs menu-item-115076 ubermenu-item-level-1 ubermenu-column ubermenu-column-full ubermenu-tab-layout-left"><ul  class="ubermenu-tabs-group ubermenu-column ubermenu-column-1-5 ubermenu-submenu ubermenu-submenu-id-115076 ubermenu-submenu-type-auto ubermenu-submenu-type-tabs-group"  ><li id="menu-item-122869" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-122869 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/ask-paul/"><span class="ubermenu-target-title ubermenu-target-text">Ask Paul by Paul McBride</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-122869 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115085] count[4] --><li id="menu-item-115085-post-130176" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115085 ubermenu-item-115085-post-130176 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/04/ask-paul-can-wide-deck-cylinders-be-used-in-my-narrow-deck-engine/"><span class="ubermenu-target-title ubermenu-target-text">Ask Paul: Can wide deck cylinders be used in my narrow-deck engine?</span><div class="gan-uber-excerpt clearfix"><p>Would it be an option to install the wide deck version in this airplane or is that a bad idea?</p></div></a></li><li id="menu-item-115085-post-130018" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115085 ubermenu-item-115085-post-130018 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/28/will-this-engine-work-on-the-velocity-im-building/"><span class="ubermenu-target-title ubermenu-target-text">Will this engine work on the Velocity I&#8217;m building?</span><div class="gan-uber-excerpt clearfix"><p>There is no doubt the 200 hp will make your airplane a rocket ship.</p></div></a></li><li id="menu-item-115085-post-130015" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115085 ubermenu-item-115085-post-130015 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/09/will-this-mount-fit-my-engine/"><span class="ubermenu-target-title ubermenu-target-text">Will this mount fit my engine?</span><div class="gan-uber-excerpt clearfix"><p>Conical type mounts are used on the Lycoming O-235-C series of engines and several different models of Lycoming O-320-A, B, and C series.</p></div></a></li><li id="menu-item-115085-post-129894" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115085 ubermenu-item-115085-post-129894 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/02/can-i-use-mogas-in-this-lycoming-engine/"><span class="ubermenu-target-title ubermenu-target-text">Can I use mogas in this Lycoming engine?</span><div class="gan-uber-excerpt clearfix"><p>Always be certain to ask many questions before putting any money on the table!</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115085] --></ul></li><li id="menu-item-122866" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-122866 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/human-factors/"><span class="ubermenu-target-title ubermenu-target-text">Human Factors by Jeffrey Madison</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-122866 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115086] count[4] --><li id="menu-item-115086-post-130209" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115086 ubermenu-item-115086-post-130209 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/24/human-factors-mindset/"><span class="ubermenu-target-title ubermenu-target-text">Human Factors: Mindset</span><div class="gan-uber-excerpt clearfix"><p>When it comes to mindset, pilots must possess a fixed mindset, but be able to adapt when needed.</p></div></a></li><li id="menu-item-115086-post-129712" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115086 ubermenu-item-115086-post-129712 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/09/18/miscommunication-common-at-airshows/"><span class="ubermenu-target-title ubermenu-target-text">Miscommunication common at airshows</span><div class="gan-uber-excerpt clearfix"><p>Even when NOTAMs are issued, the human factor leads to miscommunication.</p></div></a></li><li id="menu-item-115086-post-129167" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115086 ubermenu-item-115086-post-129167 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/08/25/self-doubt-is-a-good-thing/"><span class="ubermenu-target-title ubermenu-target-text">Self-doubt is a good thing</span><div class="gan-uber-excerpt clearfix"><p>Our ability to trust our inner doubt can be the difference between an NMAC and an uneventful flight.</p></div></a></li><li id="menu-item-115086-post-128544" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115086 ubermenu-item-115086-post-128544 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/07/25/animals-on-board/"><span class="ubermenu-target-title ubermenu-target-text">Flying with animals</span><div class="gan-uber-excerpt clearfix"><p>Our canine and other companions deserve our protection.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115086] --></ul></li><li id="menu-item-122863" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-122863 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/of-wings-things/"><span class="ubermenu-target-title ubermenu-target-text">Of Wings &#038; Things by Frederick A. Johnsen</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-122863 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115088] count[4] --><li id="menu-item-115088-post-130463" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115088 ubermenu-item-115088-post-130463 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/06/parks-air-college-in-the-1920s-build-it-fly-it-teach-it/"><span class="ubermenu-target-title ubermenu-target-text">Parks Air College in the 1920s: Build it, fly it, teach it</span><div class="gan-uber-excerpt clearfix"><p>Parks' bag of tricks included having students build aircraft that were used in the college's flight training program.</p></div></a></li><li id="menu-item-115088-post-129940" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115088 ubermenu-item-115088-post-129940 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/10/commandos-go-civilian/"><span class="ubermenu-target-title ubermenu-target-text">Commandos go civilian</span><div class="gan-uber-excerpt clearfix"><p>Commandos hauled freight across the United States for decades after World War II.</p></div></a></li><li id="menu-item-115088-post-129342" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115088 ubermenu-item-115088-post-129342 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/09/05/lockheed-constitution-on-the-cusp-of-change/"><span class="ubermenu-target-title ubermenu-target-text">Lockheed Constitution on the cusp of change</span><div class="gan-uber-excerpt clearfix"><p>Just two Lockheed Constitutions were built.</p></div></a></li><li id="menu-item-115088-post-128623" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115088 ubermenu-item-115088-post-128623 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/08/05/douglas-c-1-heads-the-air-force-transport-family-tree/"><span class="ubermenu-target-title ubermenu-target-text">Douglas C-1 heads the Air Force transport family tree</span><div class="gan-uber-excerpt clearfix"><p>In the history of the Air Force, the old Douglas C-1 of the 1920s was cast as a supporting player.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115088] --></ul></li><li id="menu-item-122861" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-122861 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/politics-for-pilots/"><span class="ubermenu-target-title ubermenu-target-text">Politics for Pilots by Jamie Beckett</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-122861 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115089] count[4] --><li id="menu-item-115089-post-130837" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115089 ubermenu-item-115089-post-130837 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/12/to-your-health/"><span class="ubermenu-target-title ubermenu-target-text">To your health</span><div class="gan-uber-excerpt clearfix"><p>The barriers to getting into aviation are falling — or at least the fence that has kept folks out has been lowered, several gates have been left open, and the guard shack is only manned on a part-time basis.</p></div></a></li><li id="menu-item-115089-post-130677" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115089 ubermenu-item-115089-post-130677 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/05/there-are-moments/"><span class="ubermenu-target-title ubermenu-target-text">There are moments…</span><div class="gan-uber-excerpt clearfix"><p>There are moments of great beauty and wonder in the air. There are also moments of concern, with maybe a pinch of fear, lurking over the horizon. </p></div></a></li><li id="menu-item-115089-post-130591" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115089 ubermenu-item-115089-post-130591 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/29/advancing-in-reverse/"><span class="ubermenu-target-title ubermenu-target-text">Advancing in reverse</span><div class="gan-uber-excerpt clearfix"><p>Our aeronautical future shows every indication of being just flat out amazing.</p></div></a></li><li id="menu-item-115089-post-130438" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115089 ubermenu-item-115089-post-130438 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/22/not-gone-just-somewhere-else/"><span class="ubermenu-target-title ubermenu-target-text">Not gone, just somewhere else</span><div class="gan-uber-excerpt clearfix"><p>The plane wasn’t gone, it was just somewhere else, doing what it does, bringing smiles to new faces and teaching lessons that need to be learned.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115089] --></ul></li><li id="menu-item-122858" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-122858 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/splog/"><span class="ubermenu-target-title ubermenu-target-text">SPLOG by Dan Johnson</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-122858 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115090] count[4] --><li id="menu-item-115090-post-130566" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115090 ubermenu-item-115090-post-130566 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/03/lsa-sales-on-the-rise/"><span class="ubermenu-target-title ubermenu-target-text">Blue skies for LSA</span><div class="gan-uber-excerpt clearfix"><p>The good news is that aircraft are selling and pilots are flying more than ever. </p></div></a></li><li id="menu-item-115090-post-129932" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115090 ubermenu-item-115090-post-129932 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/09/30/3-ways-to-buy-a-used-lsa/"><span class="ubermenu-target-title ubermenu-target-text">3 ways to buy a used LSA</span><div class="gan-uber-excerpt clearfix"><p>The market for used LSA is growing, which is good news for all of general aviation.</p></div></a></li><li id="menu-item-115090-post-129472" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115090 ubermenu-item-115090-post-129472 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/09/02/oshkosh-2019-winners/"><span class="ubermenu-target-title ubermenu-target-text">Oshkosh 2019 winners</span><div class="gan-uber-excerpt clearfix"><p>Many aircraft at Oshkosh caught the eye of our LSA expert.</p></div></a></li><li id="menu-item-115090-post-128747" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115090 ubermenu-item-115090-post-128747 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/07/21/flying-into-oshkosh-at-14-in-an-ultralight/"><span class="ubermenu-target-title ubermenu-target-text">Flying into Oshkosh at 14 in an ultralight</span><div class="gan-uber-excerpt clearfix"><p>A 14-year-old ultralight pilot flies into Oshkosh for the big show.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115090] --></ul></li><li id="menu-item-122856" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-122856 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/touch-go/"><span class="ubermenu-target-title ubermenu-target-text">Touch &#038; Go by Ben Sclair</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-122856 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115091] count[4] --><li id="menu-item-115091-post-130835" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115091 ubermenu-item-115091-post-130835 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/11/13/the-entertaining-and-insightful-conversation-around-garmins-autoland/"><span class="ubermenu-target-title ubermenu-target-text">The entertaining and insightful conversation around Garmin&#8217;s Autoland</span><div class="gan-uber-excerpt clearfix"><p>My favorite part of just about any story are the reader comments.</p></div></a></li><li id="menu-item-115091-post-130560" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115091 ubermenu-item-115091-post-130560 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/30/a-logbook-fail/"><span class="ubermenu-target-title ubermenu-target-text">A logbook fail</span><div class="gan-uber-excerpt clearfix"><p>Why restrict ourselves to two narrow lines to document all the juicy details a magical flight holds.</p></div></a></li><li id="menu-item-115091-post-130332" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115091 ubermenu-item-115091-post-130332 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/16/build-your-own-hud/"><span class="ubermenu-target-title ubermenu-target-text">Build your own HUD</span><div class="gan-uber-excerpt clearfix"><p>If you are at all handy, computer-wise, this might make for a fun project that has the potential to open your eyes to the traffic around you, while keeping more money in your wallet, so you can actually go flying.</p></div></a></li><li id="menu-item-115091-post-130109" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115091 ubermenu-item-115091-post-130109 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/10/07/nbaa-is-about-to-get-professional/"><span class="ubermenu-target-title ubermenu-target-text">NBAA is about to get Professional</span><div class="gan-uber-excerpt clearfix"><p>Later this month, the National Business Aviation Association (NBAA) will host its annual Business Aviation Convention &amp; Exhibition in Las Vegas. Oct. 22-24, 2019, to be exact.



New this year will be the roll-out of the "Professional Member" category.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115091] --></ul></li><li id="menu-item-122857" class="ubermenu-tab ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-122857 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/tag/vissers-voice/"><span class="ubermenu-target-title ubermenu-target-text">Visser&#8217;s Voice by Ben Visser</span></a><ul  class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-4-5 ubermenu-submenu ubermenu-submenu-id-122857 ubermenu-submenu-type-tab-content-panel"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[115092] count[4] --><li id="menu-item-115092-post-129658" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115092 ubermenu-item-115092-post-129658 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/09/25/oshkosh-whats-new-in-fuels-and-lubricants/"><span class="ubermenu-target-title ubermenu-target-text">Oshkosh: What&#8217;s new in fuels and lubricants</span><div class="gan-uber-excerpt clearfix"><p>In a word or two... not much.</p></div></a></li><li id="menu-item-115092-post-129078" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115092 ubermenu-item-115092-post-129078 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/08/12/mostly-good-news-out-of-oshkosh/"><span class="ubermenu-target-title ubermenu-target-text">Mostly good news out of Oshkosh</span><div class="gan-uber-excerpt clearfix"><p>EAA AirVenture Oshkosh 2019 was an excellent show, with plenty of good news for GA.</p></div></a></li><li id="menu-item-115092-post-128492" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115092 ubermenu-item-115092-post-128492 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/07/17/the-bigger-question-2/"><span class="ubermenu-target-title ubermenu-target-text">The bigger question</span><div class="gan-uber-excerpt clearfix"><p>Without new technology, GA will die.</p></div></a></li><li id="menu-item-115092-post-127816" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-115092 ubermenu-item-115092-post-127816 ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/2019/06/20/just-the-facts-2/"><span class="ubermenu-target-title ubermenu-target-text">Just the facts</span><div class="gan-uber-excerpt clearfix"><p>Who wins in court cases involving general aviation? Attorneys and expert witnesses, while all of GA loses.</p></div></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[115092] --></ul></li></ul></li><!-- end Tabs: [Tabs] 115076 --></ul></li><li id="menu-item-77967" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-77967 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/calendar/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Events</span></a></li><li id="menu-item-79146" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-item-79146 ubermenu-item-level-0 ubermenu-column ubermenu-column-natural ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/classifieds/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Classifieds</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-79146 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-left_edge_item"  ><li id="menu-item-103718" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-103718 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-natural" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/classifieds/place-classified-ad/"><span class="ubermenu-target-title ubermenu-target-text">Place Classified Ad</span></a></li></ul></li><li id="menu-item-121420" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-121420 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/aviation-job-search/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Aviation Job Search</span></a></li><li id="menu-item-115101" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-115101 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="#" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">More</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-115101 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-left_edge_item"  ><li id="menu-item-115104" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115104 ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-8" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/about/"><span class="ubermenu-target-title ubermenu-target-text">About</span></a></li><li id="menu-item-115109" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-115109 ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-3 ubermenu-has-submenu-stack" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="#"><span class="ubermenu-target-title ubermenu-target-text">How Do I</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-115109 ubermenu-submenu-type-auto ubermenu-submenu-type-stack"  ><li id="menu-item-115105" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115105 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/advertise/"><span class="ubermenu-target-title ubermenu-target-text">Advertise</span></a></li><li id="menu-item-115106" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115106 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/contact/"><span class="ubermenu-target-title ubermenu-target-text">Contact Us</span></a></li><li id="menu-item-115107" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115107 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/writers-guidelines/"><span class="ubermenu-target-title ubermenu-target-text">Writer&#8217;s Guidelines</span></a></li><li id="menu-item-115108" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115108 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-full" ><a class="ubermenu-target ubermenu-item-layout-text_only" href="https://generalaviationnews.com/photographers-guidelines/"><span class="ubermenu-target-title ubermenu-target-text">Photographer&#8217;s Guidelines</span></a></li></ul></li><li id="menu-item-115182" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-115182 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-stack" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="#"><span class="ubermenu-target-title ubermenu-target-text">Digital Editions</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-115182 ubermenu-submenu-type-auto ubermenu-submenu-type-stack"  ><li id="menu-item-115183" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115183 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/general-aviation-news-digital-edition/"><span class="ubermenu-target-title ubermenu-target-text">General Aviation News</span></a></li><li id="menu-item-115184" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115184 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/sun-n-fun-today/"><span class="ubermenu-target-title ubermenu-target-text">SUN ’n FUN Today</span></a></li></ul></li></ul></li><li id="menu-item-115185" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-115185 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/cs/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Subscribe</span></a></li><li id="menu-item-116332" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-item-116332 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/photo-of-the-day/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Photo of the day</span></a><ul  class="ubermenu-submenu ubermenu-submenu-id-116332 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width"  ><!-- begin Dynamic Posts: [Dynamic Posts] ID[116331] count[5] --><li class=" ubermenu-autocolumn menu-item-116331-col-0 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-5 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-116331-col-0"><ul  class="ubermenu-submenu ubermenu-submenu-id-116331-col-0 ubermenu-submenu-type-stack"  ><li id="menu-item-116331-post-130647" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-116331 ubermenu-item-116331-post-130647 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-image_only ubermenu-content-align-center menu-pic-of-day" href="https://generalaviationnews.com/2019/11/13/picture-of-the-day-dual-low-passes/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/Para-trikes-300x199.jpg" srcset="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/Para-trikes-300x199.jpg 300w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/Para-trikes-125x83.jpg 125w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/Para-trikes-768x509.jpg 768w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/Para-trikes.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="240" alt="Para-trikes"  /></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-116331-col-1 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-5 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-116331-col-1"><ul  class="ubermenu-submenu ubermenu-submenu-id-116331-col-1 ubermenu-submenu-type-stack"  ><li id="menu-item-116331-post-130160" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-116331 ubermenu-item-116331-post-130160 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-image_only ubermenu-content-align-center menu-pic-of-day" href="https://generalaviationnews.com/2019/11/11/picture-of-the-day-heavy-clouds/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/72752870-28E4-4F67-8BB9-BFB300A6F0DA-300x225.jpeg" srcset="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/72752870-28E4-4F67-8BB9-BFB300A6F0DA-300x225.jpeg 300w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/72752870-28E4-4F67-8BB9-BFB300A6F0DA-125x94.jpeg 125w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/72752870-28E4-4F67-8BB9-BFB300A6F0DA-768x576.jpeg 768w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/72752870-28E4-4F67-8BB9-BFB300A6F0DA.jpeg 1200w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="240" alt="72752870-28E4-4F67-8BB9-BFB300A6F0DA"  /></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-116331-col-2 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-5 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-116331-col-2"><ul  class="ubermenu-submenu ubermenu-submenu-id-116331-col-2 ubermenu-submenu-type-stack"  ><li id="menu-item-116331-post-130188" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-116331 ubermenu-item-116331-post-130188 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-image_only ubermenu-content-align-center menu-pic-of-day" href="https://generalaviationnews.com/2019/11/10/picture-of-the-day-time-to-depart/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/kdtl-300x136.jpg" srcset="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/kdtl-300x136.jpg 300w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/kdtl-125x57.jpg 125w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/kdtl-768x348.jpg 768w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/kdtl.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="240" alt="kdtl"  /></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-116331-col-3 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-5 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-116331-col-3"><ul  class="ubermenu-submenu ubermenu-submenu-id-116331-col-3 ubermenu-submenu-type-stack"  ><li id="menu-item-116331-post-130228" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-116331 ubermenu-item-116331-post-130228 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-image_only ubermenu-content-align-center menu-pic-of-day" href="https://generalaviationnews.com/2019/11/07/picture-of-the-day-early-morning-flight-out-of-chilliwack/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/20542757-AE67-4C9A-B4DE-65940594ADD2-300x225.jpeg" srcset="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/20542757-AE67-4C9A-B4DE-65940594ADD2-300x225.jpeg 300w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/20542757-AE67-4C9A-B4DE-65940594ADD2-125x94.jpeg 125w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/20542757-AE67-4C9A-B4DE-65940594ADD2-768x576.jpeg 768w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/20542757-AE67-4C9A-B4DE-65940594ADD2.jpeg 1200w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="240" alt="20542757-AE67-4C9A-B4DE-65940594ADD2"  /></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-116331-col-4 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-5 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-116331-col-4"><ul  class="ubermenu-submenu ubermenu-submenu-id-116331-col-4 ubermenu-submenu-type-stack"  ><li id="menu-item-116331-post-130666" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-dynamic-post ubermenu-item-116331 ubermenu-item-116331-post-130666 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-image_only ubermenu-content-align-center menu-pic-of-day" href="https://generalaviationnews.com/2019/11/06/picture-of-the-day-a-dusty-high-sierra-fly-in/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Cub.dust_-300x169.jpg" srcset="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Cub.dust_-300x169.jpg 300w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Cub.dust_-125x70.jpg 125w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Cub.dust_-768x432.jpg 768w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Cub.dust_.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="240" alt="Cub.dust"  /></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[116331] --><li id="menu-item-116335" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-116335 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/photo-of-the-day/"><span class="ubermenu-target-title ubermenu-target-text">See all photos of the day</span></a></li><li id="menu-item-116334" class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-116334 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://generalaviationnews.com/submit-a-picture-of-the-day/"><span class="ubermenu-target-title ubermenu-target-text">Submit Your Picture of the Day</span></a></li></ul></li></ul></nav>
<!-- End UberMenu -->
</div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-130887 post type-post status-publish format-standard has-post-thumbnail category-news tag-airport tag-aviation-news tag-general-aviation-2 entry"><header class="entry-header"><h1 class="entry-title">Aviation Day at KFMY</h1>
<p class="entry-meta"><time class="entry-time">November 14, 2019</time> by <span class="entry-author"><a href="https://generalaviationnews.com/author/ganstaff/" class="entry-author-link" rel="author"><span class="entry-author-name">General Aviation News Staff</span></a></span> <span class="entry-comments-link"><a href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/#respond">Leave a Comment</a></span> </p></header><div class="entry-content">
<p>FORT MYERS, Florida — Aviation Day 2019 will be held Saturday, Nov. 16, at <a href="https://www.flylcpa.com/fmy/" target="_blank" rel="noreferrer noopener" aria-label=" (opens in a new tab)">Page Field</a> (KFMY) will open its doors to the community Saturday, Nov. 16, for Aviation Day 2019.</p>



<p>Aviation Day is a free annual community event hosted by the Lee County Port Authority to increase community awareness of the airport.</p>



<span id="more-130887"></span>



<figure class="wp-block-image"><img data-attachment-id="130888" data-permalink="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/aviation-day-page-field/" data-orig-file="https://generalaviationnews.com/wp-content/uploads/2019/11/Aviation-Day-Page-Field.jpg" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Aviation-Day-Page-Field" data-image-description="" data-medium-file="https://generalaviationnews.com/wp-content/uploads/2019/11/Aviation-Day-Page-Field-300x169.jpg" data-large-file="https://generalaviationnews.com/wp-content/uploads/2019/11/Aviation-Day-Page-Field-1200x675.jpg" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Aviation-Day-Page-Field-1200x675.jpg" alt="" class="wp-image-130888" srcset="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Aviation-Day-Page-Field.jpg 1200w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Aviation-Day-Page-Field-125x70.jpg 125w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Aviation-Day-Page-Field-300x169.jpg 300w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Aviation-Day-Page-Field-768x432.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /></figure>



<p>The event, which runs from 10 a.m. to 3 p.m., is held on the ramp on the north side of Page Field off North Airport Road, east of U.S. 41 and south of Colonial Boulevard. Parking is available off North Airport Road and U.S. 41 with complimentary shuttle bus transportation to the event.</p>



<p>There will be two featured aircraft at this year’s event: A Douglas C-54E and a Douglas C-47 Skytrain.</p>



<p>The Douglas C-54E &#8220;Spirit of Freedom&#8221; is a four-engine military transport aircraft used during World War II, the Korean War, and the Berlin Airlift. Visitors will step back in time as they view a flying museum and memorial housed in the interior of this original aircraft.</p>



<figure class="wp-block-image"><img data-attachment-id="130889" data-permalink="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/sony-dsc-37/" data-orig-file="https://generalaviationnews.com/wp-content/uploads/2019/11/Tico-Belle.jpg" data-orig-size="1200,767" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;DSLR-A200&quot;,&quot;caption&quot;:&quot;SONY DSC&quot;,&quot;created_timestamp&quot;:&quot;1394988927&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;300&quot;,&quot;iso&quot;:&quot;125&quot;,&quot;shutter_speed&quot;:&quot;0.002&quot;,&quot;title&quot;:&quot;SONY DSC&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="SONY DSC" data-image-description="" data-medium-file="https://generalaviationnews.com/wp-content/uploads/2019/11/Tico-Belle-300x192.jpg" data-large-file="https://generalaviationnews.com/wp-content/uploads/2019/11/Tico-Belle-1200x767.jpg" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Tico-Belle-1200x767.jpg" alt="" class="wp-image-130889" srcset="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Tico-Belle.jpg 1200w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Tico-Belle-125x80.jpg 125w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Tico-Belle-300x192.jpg 300w, https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/Tico-Belle-768x491.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><figcaption>Tico Belle.</figcaption></figure>



<p>The Douglas C-47 Skytrain “Tico Belle” was part of the Normandy Invasion of World War II, commemorating the 75th anniversary of the historic event this year.</p>



<p>Other attractions will include general aviation aircraft and helicopter exhibits, plane and helicopter rides (for a fee), demonstrations by airport police and fire departments, aviation-themed shopping, food, and more. In addition, there will be free children’s activities and face painting, sponsored by Kimley-Horn and Suncoast Credit Union.</p>



<p>Airport officials are asking those coming to Aviation Day 2019 to help our local community by bringing a non-perishable food item to benefit The Harry Chapin Food Bank of Southwest Florida.</p>



<p>Page Field serves general and business aviation with more than 98,000 aircraft operations annually. </p>
<span id="tve_leads_end_content" style="display: block; visibility: hidden; border: 1px solid transparent;"></span><div class='ctx-subscribe-container ctx-personalization-container ctx_default_placement ctx-clearfix'></div><div class='ctx-social-container ctx_default_placement ctx-clearfix'></div><div class='ctx-module-container ctx_default_placement ctx-clearfix'></div><div class="tve-leads-post-footer tve-tl-anim tve-leads-track-post_footer-5 tl-anim-instant"><div class="tl-style" id="tve_tcb2_set-021" data-state="5" data-form-state=""><style type="text/css" class="tve_custom_style">@import url("//fonts.googleapis.com/css?family=Roboto:400,500,900,300,700&subset=latin");@media (min-width: 300px){[data-css="tve-u-105b7d9a0dd5f32"] { font-weight: 400 !important; font-family: Roboto !important; }:not(#tve) [data-css="tve-u-165b7d9a0dd60c2"]:hover button { background-color: rgb(7, 133, 115) !important; }:not(#tve) [data-css="tve-u-135b7d9a0dd5ff5"]:hover input { color: rgb(0, 109, 94); background-color: rgb(159, 202, 196) !important; }:not(#tve) [data-css="tve-u-145b7d9a0dd6036"] > :first-child { color: rgb(216, 216, 216); }[data-css="tve-u-75b7d9a0dd5e6e"] { margin-bottom: 20px !important; }[data-css="tve-u-25b7d9a0dd5cce"] { padding-top: 0px !important; padding-bottom: 0px !important; }[data-css="tve-u-15b7d9a0dd598c"] { margin-top: 10px !important; margin-bottom: 20px !important; }[data-css="tve-u-115b7d9a0dd5f74"] { margin-top: 0px !important; margin-bottom: 0px !important; }[data-css="tve-u-05b7d9a0dd592f"] { overflow: hidden; background-color: rgb(42, 56, 115) !important; border-radius: 10px !important; padding: 20px !important; }:not(#tve) [data-css="tve-u-165b7d9a0dd60c2"] button { font-size: 22px; line-height: 30px; font-family: Roboto; border-radius: 5px; overflow: hidden; border: none; background-color: rgb(0, 109, 94) !important; font-weight: bold !important; }:not(#tve) [data-css="tve-u-135b7d9a0dd5ff5"] input { line-height: 28px; color: rgb(51, 51, 51); font-family: Roboto; font-weight: 300; border: none; border-radius: 5px; overflow: hidden; background-image: none !important; padding: 14px 18px !important; }[data-css="tve-u-95b7d9a0dd5ef2"] { line-height: 27px !important; }:not(#tve) [data-css="tve-u-95b7d9a0dd5ef2"] { font-family: Roboto; font-weight: 300; font-size: 18px !important; color: rgb(255, 255, 255) !important; }[data-css="tve-u-85b7d9a0dd5eb0"] strong { font-weight: 500; }[data-css="tve-u-85b7d9a0dd5eb0"] { line-height: 40px !important; }:not(#tve) [data-css="tve-u-85b7d9a0dd5eb0"] { font-family: Roboto; font-weight: 300; color: rgb(255, 255, 255) !important; font-size: 36px !important; }[data-css="tve-u-155b7d9a0dd6080"] { max-width: 30%; }[data-css="tve-u-125b7d9a0dd5fb4"] { max-width: 70%; }[data-css="tve-u-55b7d9a0dd5dba"] { max-width: 75%; }[data-css="tve-u-35b7d9a0dd5d25"] { max-width: 25%; }[data-css="tve-u-45b7d9a0dd5d68"] { float: none; margin-left: auto; margin-right: auto; width: 155px; margin-top: 0px !important; margin-bottom: 0px !important; }}@media (max-width: 767px){[data-css="tve-u-05b7d9a0dd592f"] { padding: 14px !important; }[data-css="tve-u-65b7d9a0dd5e1d"] { text-align: center; }[data-css="tve-u-85b7d9a0dd5eb0"] { line-height: 1.2em !important; }:not(#tve) [data-css="tve-u-85b7d9a0dd5eb0"] { font-size: 28px !important; }[data-css="tve-u-45b7d9a0dd5d68"] { width: 90px; margin-bottom: 10px !important; }}</style><style type="text/css" class="tve_user_custom_style">.tve-leads-conversion-object .thrv_heading h1,.tve-leads-conversion-object .thrv_heading h2,.tve-leads-conversion-object .thrv_heading h3{margin:0;padding:0}.tve-leads-conversion-object .thrv_text_element p,.tve-leads-conversion-object .thrv_text_element h1,.tve-leads-conversion-object .thrv_text_element h2,.tve-leads-conversion-object .thrv_text_element h3{margin:0}</style><style type="text/css" class="tve_global_style"></style><div class="tve-leads-conversion-object" data-tl-type="post_footer"><div class="tve_flt"><div id="tve_editor" class="tve_shortcode_editor"><div class="thrv-leads-form-box tve_no_drag tve_no_icons thrv_wrapper tve_editor_main_content thrv-leads-in-content tve_empty_dropzone" style="" data-css="tve-u-05b7d9a0dd592f"><div class="thrv_wrapper thrv-columns" style="" data-css="tve-u-15b7d9a0dd598c"><div class="tcb-flex-row tcb-resized tcb--cols--2" data-css="tve-u-25b7d9a0dd5cce"><div class="tcb-flex-col" data-css="tve-u-35b7d9a0dd5d25" style=""><div class="tcb-col tve_empty_dropzone"><div class="thrv_wrapper tve_image_caption" data-css="tve-u-45b7d9a0dd5d68" style=""><span class="tve_image_frame" style="width: 100%;"><img class="tve_image wp-image-2421" alt="" width="155" height="155" title="set_21_icon" data-id="2421" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/uploads/tve_leads_templates/post_footer/tcb2_set-021/images/set_21_icon.png" style="width: 100%;" scale="0"></span></div></div></div><div class="tcb-flex-col" data-css="tve-u-55b7d9a0dd5dba" style=""><div class="tcb-col tve_empty_dropzone" style="" data-css="tve-u-65b7d9a0dd5e1d"><div class="thrv_wrapper thrv_text_element tve_empty_dropzone" style="" data-css="tve-u-75b7d9a0dd5e6e"><p data-css="tve-u-85b7d9a0dd5eb0" data-default="Enter your text here..."><strong>Be a better informed pilot.</strong></p></div><div class="thrv_wrapper thrv_text_element tve_empty_dropzone" style=""><p data-css="tve-u-95b7d9a0dd5ef2" data-default="Enter your text here..."><span data-css="tve-u-105b7d9a0dd5f32" style="font-weight: 400; font-family: Roboto;">Join over 110,000 readers each month and get real-world news and information direct to your inbox, each day.</span></p></div></div></div></div></div><div class="thrv_wrapper thrv_lead_generation Better Informed Pilot" data-connection="api" style="" data-css="tve-u-115b7d9a0dd5f74"><input type="hidden" class="tve-lg-err-msg" value="{&quot;email&quot;:&quot;Email address invalid&quot;,&quot;phone&quot;:&quot;Phone number invalid&quot;,&quot;password&quot;:&quot;Password invalid&quot;,&quot;passwordmismatch&quot;:&quot;Password mismatch error&quot;,&quot;required&quot;:&quot;Required field missing&quot;}">
<div class="thrv_lead_generation_container tve_clearfix">
<form action="#" method="post" novalidate="novalidate">
<div class="tve_lead_generated_inputs_container tve_clearfix tve_empty_dropzone">
<div class="thrv_wrapper thrv-columns"><div class="tcb-flex-row tcb--cols--2 tcb-resized"><div class="tcb-flex-col" data-css="tve-u-125b7d9a0dd5fb4" style=""><div class="tcb-col tve_empty_dropzone"><div class="tve_lg_input_container tve_lg_input tcb-icon-display tve_empty_dropzone" data-css="tve-u-135b7d9a0dd5ff5"><div class="thrv_wrapper thrv_icon" style="" data-css="tve-u-145b7d9a0dd6036"><svg class="tcb-icon" viewBox="0 0 28 28" data-name="envelope">
<title>envelope</title>
<path d="M28 11.094v12.406c0 1.375-1.125 2.5-2.5 2.5h-23c-1.375 0-2.5-1.125-2.5-2.5v-12.406c0.469 0.516 1 0.969 1.578 1.359 2.594 1.766 5.219 3.531 7.766 5.391 1.313 0.969 2.938 2.156 4.641 2.156h0.031c1.703 0 3.328-1.188 4.641-2.156 2.547-1.844 5.172-3.625 7.781-5.391 0.562-0.391 1.094-0.844 1.563-1.359zM28 6.5c0 1.75-1.297 3.328-2.672 4.281-2.438 1.687-4.891 3.375-7.313 5.078-1.016 0.703-2.734 2.141-4 2.141h-0.031c-1.266 0-2.984-1.437-4-2.141-2.422-1.703-4.875-3.391-7.297-5.078-1.109-0.75-2.688-2.516-2.688-3.938 0-1.531 0.828-2.844 2.5-2.844h23c1.359 0 2.5 1.125 2.5 2.5z"></path>
</svg></div>
<input type="email" data-field="email" data-required="1" data-validation="email" name="email" placeholder="Email" data-placeholder="Email" class="" style="">
</div></div></div><div class="tcb-flex-col" data-css="tve-u-155b7d9a0dd6080" style=""><div class="tcb-col tve_empty_dropzone"><div class="tve_lg_input_container tve_submit_container tve_lg_submit" data-css="tve-u-165b7d9a0dd60c2">
<button type="submit" class="tve-froala" style="">Join for Free!</button>
</div></div></div></div></div>
</div>
<input type="hidden" name="__tcb_lg_fc" id="__tcb_lg_fc" value="YToxOntzOjE0OiJhY3RpdmVjYW1wYWlnbiI7czoxOiIxIjt9"><input id="_submit_option" type="hidden" name="_submit_option" value="message"><input id="__tcb_lg_msg" type="hidden" name="__tcb_lg_msg" value="YToyOntzOjU6ImVycm9yIjtzOjY6IkVycm9yISI7czo3OiJzdWNjZXNzIjtzOjM5OiJUaGFuayBZb3UuIEVuam95IFRoZSBQdWxzZSBvZiBBdmlhdGlvbi4iO30="><input type="hidden" id="activecampaign_form" class="tve-api-extra" name="activecampaign_form" value="0"><input type="hidden" id="activecampaign_tags" class="tve-api-extra" name="activecampaign_tags" value="Source - GAN Article Footer"></form>
</div>
</div></div></div></div></div></div></div><span class="ctx-article-root"><!-- --></span><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share This Story</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-130887" class="share-facebook sd-button share-icon no-text" href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-130887" class="share-twitter sd-button share-icon no-text" href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-130887" class="share-linkedin sd-button share-icon no-text" href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://generalaviationnews.com/2019/11/14/aviation-day-at-kfmy/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div><footer class="entry-footer"></footer></article><div class="after-entry" class="widget-area"><section id="custom_html-7" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><!-- BEGIN ADVERTSERVE CODE -->
<div id="avp_zid_21">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_21', alias: '/', type: 'banner', zid: 21, pid: 0 });
</script>
</div>
<!-- END ADVERTSERVE CODE --></div></div></section>
</div><section class="author-box"><img src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/user-avatar/user-avatar-pic.php?src=https://generalaviationnews.com/wp-content/uploads/avatars/2456/1361899707-bpfull.jpg&#038;w=70&#038;id=2456&#038;random=1542168180" alt="" class=" avatar  avatar-70  photo user-2456-avatar" width="70" height="70" /><h4 class="author-box-title">About <span itemprop="name">General Aviation News Staff</span></h4><div class="author-box-content" itemprop="description"></div></section><div class="comment-policy-holder"><p>General Aviation News reserves the right to delete snarky, offensive or off-topic comments. See our <a href="/comment-policy/" target="_blank">Comment Policy</a> for more details.</p></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/11/14/aviation-day-at-kfmy/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://generalaviationnews.com/wp-comments-post.php?wpe-comment-post=ganews" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='130887' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="61ac8d0c07" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="191"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://generalaviationnews.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://generalaviationnews.com/?s={s}"></form></div></section>
<section id="custom_html-5" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><!-- BEGIN ADVERTSERVE CODE -->
<div id="avp_zid_17">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_17', alias: '/', type: 'banner', zid: 17, pid: 0 });
</script>
</div>
<!-- END ADVERTSERVE CODE --></div></div></section>
<section id="custom_html-6" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><!-- BEGIN ADVERTSERVE CODE -->
<div id="avp_zid_18">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_18', alias: '/', type: 'banner', zid: 18, pid: 0 });
</script>
</div>
<!-- END ADVERTSERVE CODE --></div></div></section>
<section id="js_jobs_widget-2" class="widget widget_js_jobs_widget"><div class="widget-wrap"><h4 class="widget-title widgettitle"></h4>
<div id="jobs-widget-holder"><h3>Aviation Jobs</h3><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=315728" >Hydraulic Tube Bender &raquo;</a><br /><span class="date-posted">Talentscale - Palmdale, California</span><br /><span class="date-posted">POSTED: 11/14/2019</span></p><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=439477" >Urgent Structures Mechanic &raquo;</a><br /><span class="date-posted">Talentscale - Huntsville, Alabama</span><br /><span class="date-posted">POSTED: 11/14/2019</span></p><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=403124" >Composite Technician &raquo;</a><br /><span class="date-posted">Talentscale - Palmdale, California</span><br /><span class="date-posted">POSTED: 11/14/2019</span></p><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=378220" >Composites Technician &raquo;</a><br /><span class="date-posted">Talentscale - Tehachapi, California</span><br /><span class="date-posted">POSTED: 11/14/2019</span></p><p class="job-title"><a href="/aviation-job-search/full-job-display?jobID=367661" >Airframe and Powerplant Mechanic &raquo;</a><br /><span class="date-posted">Talentscale - Harrisonburg, Virginia</span><br /><span class="date-posted">POSTED: 11/14/2019</span></p><p style="text-align: center; "><a href="/aviation-job-search/" class="button">Search all jobs</a><p></div></div></section>
<section id="custom_html-4" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_19"><script type="text/javascript">
_avp.push({ tagid: 'avp_zid_19', alias: '/', type: 'banner', zid: 19, pid: 0 });
</script></div></div></div></section>
</aside></div></div><h3 class="online-partners">Thank you to our online partners</h3><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="custom_html-8" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_22">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_22', alias: '/', type: 'banner', zid: 22, pid: 0 });
</script>
</div></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="custom_html-9" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_23">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_23', alias: '/', type: 'banner', zid: 23, pid: 0 });
</script>
</div></div></div></section>
<section id="custom_html-10" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_28">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_28', alias: '/', type: 'banner', zid: 28, pid: 0 });
</script>
</div></div></div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="custom_html-11" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_24">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_24', alias: '/', type: 'banner', zid: 24, pid: 0 });
</script>
</div></div></div></section>
<section id="custom_html-12" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_29">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_29', alias: '/', type: 'banner', zid: 29, pid: 0 });
</script>
</div></div></div></section>
</div><div class="widget-area footer-widgets-4 footer-widget-area"><section id="custom_html-13" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_25">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_25', alias: '/', type: 'banner', zid: 25, pid: 0 });
</script>
</div></div></div></section>
<section id="custom_html-14" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_30">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_30', alias: '/', type: 'banner', zid: 30, pid: 0 });
</script>
</div></div></div></section>
</div><div class="widget-area footer-widgets-5 footer-widget-area"><section id="custom_html-15" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_26">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_26', alias: '/', type: 'banner', zid: 26, pid: 0 });
</script>
</div></div></div></section>
<section id="custom_html-16" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_31">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_31', alias: '/', type: 'banner', zid: 31, pid: 0 });
</script>
</div></div></div></section>
</div><div class="widget-area footer-widgets-6 footer-widget-area"><section id="custom_html-17" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div id="avp_zid_27">
<script type="text/javascript">
_avp.push({ tagid: 'avp_zid_27', alias: '/', type: 'banner', zid: 27, pid: 0 });
</script>
</div></div></div></section>
</div></div></div><footer class="site-footer"><div class="wrap"><p>Copyright &copy; 2019  &middot; General Aviation News. All rights reserved. <a href="/privacy-policy/">Privacy Policy</a> &middot; <a href="/terms-of-service/">Terms of Service</a> </div></footer></div><script type="text/javascript">
		Contextly.ready('load', "wp\/widgets", function() {
		Contextly.WPSettings.setPostData(130887,{"ajax_nonce":"45df5ba0ff"});Contextly.ready("widgets");	});
	</script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/generalaviationnews.com\/2019\/11\/14\/aviation-day-at-kfmy\/":130887};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2019/11/14/aviation-day-at-kfmy/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201946'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tve_frontend_options = {"is_editor_page":"","page_events":[],"is_single":"1","ajaxurl":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","social_fb_app_id":"","dash_url":"https:\/\/generalaviationnews.com\/wp-content\/plugins\/thrive-visual-editor\/thrive-dashboard","translations":{"Copy":"Copy"},"post_id":"130887"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-visual-editor/editor/js/dist/frontend.min.js?ver=2.4.4.2'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-leads/js/frontend.min.js?ver=2.2.5.2'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var tve_dash_front = {"ajaxurl":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","force_ajax_send":"","is_crawler":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/thrive-visual-editor/thrive-dashboard/js/dist/frontend.min.js?ver=2.2.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ubermenu_data = {"remove_conflicts":"on","reposition_on_load":"off","intent_delay":"300","intent_interval":"100","intent_threshold":"7","scrollto_offset":"50","scrollto_duration":"1000","responsive_breakpoint":"959","accessible":"on","retractor_display_strategy":"responsive","touch_off_close":"on","collapse_after_scroll":"on","v":"3.3.1","configurations":["main"],"ajax_url":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/generalaviationnews.com\/wp-content\/plugins\/ubermenu\/","disable_mobile":"off","prefix_boost":"","aria_role_navigation":"off","aria_expanded":"off","aria_hidden":"off","aria_controls":"","aria_responsive_toggle":"off","theme_locations":{"primary":"Primary Navigation Menu","secondary":"Secondary Navigation Menu","amp-menu":"AMP Menu","amp-footer-menu":"AMP Footer Menu"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/assets/js/ubermenu.min.js?ver=3.3.1'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/ubermenu/custom/custom.js?ver=3.3.1'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.2.4'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","nonce":"e4bc703fb8","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/generalaviationnews.com\/wp-login.php?redirect_to=https%3A%2F%2Fgeneralaviationnews.com%2F2019%2F11%2F14%2Faviation-day-at-kfmy%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script async="async" type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3ukr694671p02fhcme3a1bsaiek-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
<script type="text/javascript">var tcb_post_lists=JSON.parse('[]');</script><script type="text/javascript">/*<![CDATA[*/if ( !window.TL_Const ) {var TL_Const={"security":"dd173f9af2","ajax_url":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","forms":{"post_footer":{"_key":"5","trigger":"page_load","trigger_config":{},"form_type_id":113848,"main_group_id":113847,"active_test_id":""}},"action_conversion":"tve_leads_ajax_conversion","action_impression":"tve_leads_ajax_impression","ajax_load":0,"main_group_id":113847,"display_options":{"allowed_post_types":[],"flag_url_match":false},"custom_post_data":[],"current_screen":{"screen_type":4,"screen_id":130887},"ignored_fields":["email","_captcha_size","_captcha_theme","_captcha_type","_submit_option","_use_captcha","g-recaptcha-response","__tcb_lg_fc","__tcb_lg_msg","_state","_form_type","_error_message_option","_back_url","_submit_option","url","_asset_group","_asset_option","mailchimp_optin"]};} else {ThriveGlobal.$j.extend(true, TL_Const, {"security":"dd173f9af2","ajax_url":"https:\/\/generalaviationnews.com\/wp-admin\/admin-ajax.php","forms":{"post_footer":{"_key":"5","trigger":"page_load","trigger_config":{},"form_type_id":113848,"main_group_id":113847,"active_test_id":""}},"action_conversion":"tve_leads_ajax_conversion","action_impression":"tve_leads_ajax_impression","ajax_load":0,"main_group_id":113847,"display_options":{"allowed_post_types":[],"flag_url_match":false},"custom_post_data":[],"current_screen":{"screen_type":4,"screen_id":130887},"ignored_fields":["email","_captcha_size","_captcha_theme","_captcha_type","_submit_option","_use_captcha","g-recaptcha-response","__tcb_lg_fc","__tcb_lg_msg","_state","_form_type","_error_message_option","_back_url","_submit_option","url","_asset_group","_asset_option","mailchimp_optin"]})} /*]]> */</script><script type="text/javascript">var TL_Front = TL_Front || {}; TL_Front.impressions_data = TL_Front.impressions_data || {};TL_Front.impressions_data.post_footer = {"group_id":113847,"form_type_id":113848,"variation_key":"5","active_test_id":0,"output_js":true};</script><script type="text/javascript">
	(function ($) {
	$(function () {
		var event_data = {"form_id":"tve-leads-track-post_footer-5","form_type":"post_footer"};
		event_data.source = 'page_load';
		setTimeout(function () {
			ThriveGlobal.$j(TL_Front).trigger('showform.thriveleads', event_data);
			}, 200);
		});
	})
(ThriveGlobal.$j);
</script><script type='text/javascript' src='https://stats.wp.com/e-201946.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9',blog:'35113008',post:'130887',tz:'-8',srv:'generalaviationnews.com'} ]);
	_stq.push([ 'clickTrackerInit', '35113008', '130887' ]);
</script>
</body></html>
